replace all references to xway with danube
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 Jul 2011 18:20:37 +0000 (18:20 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 7 Jul 2011 18:20:37 +0000 (18:20 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27538 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ltq-dsl-app/Makefile
package/ltq-dsl/Makefile
package/ltq-tapidemo/Config.in
package/uboot-lantiq/Makefile
target/linux/lantiq/Makefile
target/linux/lantiq/image/Makefile
target/linux/lantiq/modules.mk

index 5be052f..1b1aa36 100644 (file)
@@ -23,7 +23,7 @@ define Package/ltq-dsl-app
   CATEGORY:=Network
   TITLE:=Lantiq DSL userland tool
   URL:=http://www.lantiq.com/
-  DEPENDS:=@TARGET_lantiq_xway +kmod-ltq-dsl +libpthread
+  DEPENDS:=@TARGET_lantiq_danube +kmod-ltq-dsl +libpthread
   MAINTAINER:=John Crispin <blogic@openwrt.org> 
 endef
 
index f62bfe8..d645af7 100644 (file)
@@ -33,7 +33,7 @@ define KernelPackage/ltq-dsl
   SUBMENU:=Network Devices
   TITLE:=Lantiq dsl driver
   URL:=http://www.lantiq.com/
-  DEPENDS:=@TARGET_lantiq_xway +kmod-atm
+  DEPENDS:=@TARGET_lantiq_danube +kmod-atm
   FILES:=$(PKG_BUILD_DIR)/src/mei/lantiq_mei.ko \
        $(PKG_BUILD_DIR)/src/drv_dsl_cpe_api.ko \
        $(PKG_BUILD_DIR)/src/mei/lantiq_atm.ko
@@ -47,7 +47,7 @@ define Package/kmod-ltq-dsl-firmware/default
   SUBMENU:=Network Devices
   TITLE:=Firmware
   URL:=http://www.lantiq.com/
-  DEPENDS:=@TARGET_lantiq_xway kmod-ltq-dsl
+  DEPENDS:=@TARGET_lantiq_danube kmod-ltq-dsl
   MAINTAINER:=John Crispin <blogic@openwrt.org>
 endef
 
index 7bd0f5c..a799edd 100644 (file)
@@ -1,7 +1,7 @@
 choice
        prompt "board selection"
        depends on PACKAGE_ltq-tapidemo
-       default VOICE_CPE_TAPIDEMO_BOARD_EASY50712_V3   if TARGET_lantiq_xway
+       default VOICE_CPE_TAPIDEMO_BOARD_EASY50712_V3   if TARGET_lantiq_danube
        default VOICE_CPE_TAPIDEMO_BOARD_EASY508xx      if TARGET_lantiq_ar9
        default VOICE_CPE_TAPIDEMO_BOARD_EASY80910      if TARGET_lantiq_vr9
        help
index 943132c..404b540 100644 (file)
@@ -29,7 +29,7 @@ endif
 define Package/uboot-lantiq-template
   SECTION:=boot
   CATEGORY:=Boot Loaders
-  DEPENDS:=@TARGET_lantiq
+  DEPENDS:=@TARGET_lantiq_danube
   URL:=http://www.denx.de/wiki/U-Boot
   VARIANT:=$(1)
   TITLE:=$(1) ($(2))
index b9c2283..82e5c39 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=lantiq
 BOARDNAME:=Lantiq GPON/XWAY
 FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=xway
+DEFAULT_SUBTARGET:=danube
 
 LINUX_VERSION:=2.6.39.2
 
index 43ad0e8..f0c06fd 100644 (file)
@@ -55,7 +55,7 @@ define Image/BuildKernel/Template
        $(CP) $(KDIR)/uImage-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage
 endef
 
-ifeq ($(CONFIG_TARGET_lantiq_xway),y)
+ifeq ($(CONFIG_TARGET_lantiq_danube),y)
 define Image/BuildKernel/Profile/EASY50712
        $(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
 endef
index a4a9640..0d4ad2d 100644 (file)
@@ -29,7 +29,7 @@ USB_MENU:=USB Support
 define KernelPackage/usb-dwc-otg
   TITLE:=Synopsis DWC_OTG support
   SUBMENU:=$(USB_MENU)
-  DEPENDS+=@TARGET_lantiq_xway +kmod-usb-core
+  DEPENDS+=@TARGET_lantiq_danube +kmod-usb-core
   KCONFIG:=CONFIG_DWC_OTG \
        CONFIG_DWC_OTG_DEBUG=n \
        CONFIG_DWC_OTG_LANTIQ=y \