Make the grub timeout configurable on x86 targets
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Jan 2012 01:14:45 +0000 (01:14 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Jan 2012 01:14:45 +0000 (01:14 +0000)
Signed-off-by: Justus Winter <4winter@informatik.uni-hamburg.de>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29786 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86/image/Config.in
target/linux/x86/image/Makefile
target/linux/x86/image/menu.lst

index a9412cd..b60baea 100644 (file)
@@ -47,6 +47,13 @@ config X86_GRUB_BOOTOPTS
        help
          If you don't know, just leave it blank.
 
+config X86_GRUB_TIMEOUT
+       string "Seconds to wait before booting the default entry"
+       depends X86_GRUB_IMAGES
+       default "5"
+       help
+         If you don't know, 5 seconds is a reasonable default.
+
 config X86_VDI_IMAGES
        bool "Build VirtualBox image files (VDI)"
        depends X86_GRUB_IMAGES
index c070a10..185da10 100644 (file)
@@ -31,6 +31,8 @@ endif
 
 ROOTPART:=$(call qstrip,$(CONFIG_TARGET_ROOTFS_PARTNAME))
 
+GRUB_TIMEOUT:=$(call qstrip,$(CONFIG_X86_GRUB_TIMEOUT))
+
 ifneq ($(CONFIG_X86_GRUB_IMAGES),)
 
   BOOTOPTS:=$(call qstrip,$(CONFIG_X86_GRUB_BOOTOPTS))
@@ -64,6 +66,7 @@ ifneq ($(CONFIG_X86_GRUB_IMAGES),)
                -e 's#@SERIAL_CONFIG@#$(strip $(GRUB_SERIAL_CONFIG))#g' \
                -e 's#@TERMINAL_CONFIG@#$(strip $(GRUB_TERMINAL_CONFIG))#g' \
                -e 's#@CMDLINE@#$(strip $(call Image/cmdline/$(1)) $(BOOTOPTS) $(GRUB_CONSOLE_CMDLINE))#g' \
+               -e 's#@TIMEOUT@#$(GRUB_TIMEOUT)#g' \
                ./menu.lst > $(KDIR)/root.grub/boot/grub/menu.lst
        PADDING="$(CONFIG_TARGET_IMAGES_PAD)" PATH="$(TARGET_PATH)" ./gen_image_x86.sh \
                $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).img \
index 5f99f21..5af1e95 100644 (file)
@@ -2,7 +2,7 @@
 @TERMINAL_CONFIG@
 
 default 0
-timeout 5
+timeout @TIMEOUT@
 
 title   OpenWrt
 root    (hd0,0)