package/dnsmasq: use new service wrapper
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Nov 2011 22:58:45 +0000 (22:58 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 7 Nov 2011 22:58:45 +0000 (22:58 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28837 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/dnsmasq/Makefile
package/dnsmasq/files/dnsmasq.init

index 540d476..1294a8b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.58
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq
index 3d9060d..80ab250 100644 (file)
@@ -2,6 +2,9 @@
 # Copyright (C) 2007 OpenWrt.org
 
 START=60
+
+SERVICE_USE_PID=1
+
 DNS_SERVERS=""
 DOMAIN=""
 
@@ -397,7 +400,7 @@ start() {
        config_foreach dhcp_add dhcp
        config_foreach dhcp_cname_add cname
 
-       /usr/sbin/dnsmasq $args && {
+       service_start /usr/sbin/dnsmasq $args && {
                rm -f /tmp/resolv.conf
                [ -n "$DOMAIN" ] && echo "search $DOMAIN" >> /tmp/resolv.conf
                DNS_SERVERS="$DNS_SERVERS 127.0.0.1"
@@ -408,10 +411,10 @@ start() {
 }
 
 stop() {
-       [ -f /tmp/resolv.conf ] && {
-               rm -f /tmp/resolv.conf
-               ln -s /tmp/resolv.conf.auto /tmp/resolv.conf
+       service_stop /usr/sbin/dnsmasq && {
+               [ -f /tmp/resolv.conf ] && {
+                       rm -f /tmp/resolv.conf
+                       ln -s /tmp/resolv.conf.auto /tmp/resolv.conf
+               }
        }
-       service_kill dnsmasq /var/run/dnsmasq.pid
-       return 0
 }