prereq-build: check for "bc" (#13767)
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Jun 2013 17:14:47 +0000 (17:14 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Jun 2013 17:14:47 +0000 (17:14 +0000)
bc is required by the kernel to compute timeconsts files, add bc to the
list of prereq to build OpenWrt.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37108 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq-build.mk

index 59ea7ef..dadce81 100644 (file)
@@ -183,3 +183,7 @@ endef
 $(eval $(call Require,getopt-extended, \
        Please install an extended getopt version that supports --long \
 ))
+
+$(eval $(call RequireCommand,bc, \
+       Please install bc. \
+))