link to specific header, just to be safe
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Sep 2005 00:03:48 +0000 (00:03 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 4 Sep 2005 00:03:48 +0000 (00:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1841 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mtd/Makefile
package/mtd/mtd.c

index bfbb301..b2090a6 100644 (file)
@@ -7,6 +7,10 @@ PKG_RELEASE := 1
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
+ifeq ($(LINUX_VERSION),2.4.30)
+VER=-DLINUX_24
+endif
+
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,MTD,$(PKG_NAME),$(PKG_RELEASE),$(ARCH)))
@@ -16,7 +20,7 @@ $(PKG_BUILD_DIR)/.prepared:
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
-       $(TARGET_CC) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
+       $(TARGET_CC) -I$(LINUX_DIR)/include $(VER) $(TARGET_CFLAGS) -o $(PKG_BUILD_DIR)/mtd mtd.c
        touch $@
 
 $(IPKG_MTD): 
index 69ef064..e559864 100644 (file)
 #include <sys/reboot.h>
 #include <string.h>
 
+#ifdef LINUX_24
 #include <linux/mtd/mtd.h>
+#else
+#include <mtd/mtd-user.h>
+#endif
 
 #define TRX_MAGIC       0x30524448      /* "HDR0" */
 #define BUFSIZE (10 * 1024)