package.mk: replicate SSP and relro in both CFLAGS and LDFLAGS
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jun 2015 10:48:28 +0000 (10:48 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 18 Jun 2015 10:48:28 +0000 (10:48 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46035 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package.mk

index c69d928..7ba7401 100644 (file)
@@ -48,11 +48,13 @@ endif
 ifdef CONFIG_PKG_CC_STACKPROTECTOR_REGULAR
   ifeq ($(strip $(PKG_CC_STACKPROTECTOR_REGULAR)),1)
     TARGET_CFLAGS += -fstack-protector
+    TARGET_LDFLAGS += -fstack-protector
   endif
 endif
 ifdef CONFIG_PKG_CC_STACKPROTECTOR_STRONG
   ifeq ($(strip $(PKG_CC_STACKPROTECTOR_STRONG)),1)
     TARGET_CFLAGS += -fstack-protector-strong
+    TARGET_LDFLAGS += -fstack-protector-strong
   endif
 endif
 ifdef CONFIG_PKG_FORTIFY_SOURCE_1
@@ -68,11 +70,13 @@ endif
 ifdef CONFIG_PKG_RELRO_PARTIAL
   ifeq ($(strip $(PKG_RELRO_PARTIAL)),1)
     TARGET_CFLAGS += -Wl,-z,relro
+    TARGET_LDFLAGS += -Wl,-z,relro
   endif
 endif
 ifdef CONFIG_PKG_RELRO_FULL
   ifeq ($(strip $(PKG_RELRO_FULL)),1)
     TARGET_CFLAGS += -Wl,-z,now -Wl,-z,relro
+    TARGET_LDFLAGS += -Wl,-z,now -Wl,-z,relro
   endif
 endif