include: fix detection of installed feeds
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Aug 2014 09:12:31 +0000 (09:12 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 6 Aug 2014 09:12:31 +0000 (09:12 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42003 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/feeds.mk

index 17ce64f..97b1449 100644 (file)
@@ -8,8 +8,9 @@
 -include $(TMP_DIR)/.packagefeeds
 
 FEEDS_AVAILABLE:=$(shell $(SCRIPT_DIR)/feeds list -n)
-FEEDS_INSTALLED:=$(patsubst %.index,%,$(notdir $(wildcard $(TOPDIR)/feeds/*.index)))
+FEEDS_INSTALLED:=$(notdir $(wildcard $(TOPDIR)/package/feeds/*))
 FEEDS_ENABLED:=$(foreach feed,$(FEEDS_INSTALLED),$(if $(CONFIG_FEED_$(feed)),$(feed)))
+FEEDS_DISABLED:=$(filter-out $(FEEDS_ENABLED),$(FEEDS_INSTALLED))
 
 PKG_CONFIG_DEPENDS += \
        CONFIG_PER_FEED_REPO \