[lantiq] fixes tapi dependencies
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Aug 2012 18:56:38 +0000 (18:56 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 6 Aug 2012 18:56:38 +0000 (18:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33029 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ltq-tapi/Makefile
package/ltq-tapidemo/Makefile
package/ltq-vmmc/Makefile
package/owsip/Makefile

index ecaac2e..3027ec4 100644 (file)
@@ -22,7 +22,7 @@ define KernelPackage/ltq-tapi
   SUBMENU:=Voice over IP
   TITLE:=Lantiq TAPI subsystem
   URL:=http://www.lantiq.com/
-  DEPENDS:=+kmod-ltq-ifxos @TARGET_lantiq
+  DEPENDS:=+kmod-ltq-ifxos @(TARGET_lantiq_danube||TARGET_lantiq_falcon)
   FILES:=$(PKG_BUILD_DIR)/src/drv_tapi.ko
   AUTOLOAD:=$(call AutoLoad,20,drv_tapi)
   MAINTAINER:=John Crispin <blogic@openwrt.org>
index 0fbcce0..1c1d2b4 100644 (file)
@@ -26,7 +26,7 @@ define Package/ltq-tapidemo
   CATEGORY:=Network
   TITLE:=TAPIdemo application for Lantiq boards
   URL:=http://www.lantiq.com/
-  DEPENDS:=+kmod-ltq-tapi +kmod-ltq-vmmc +libpthread
+  DEPENDS:=+kmod-ltq-tapi +kmod-ltq-vmmc +libpthread @(TARGET_lantiq_danube||TARGET_lantiq_falcon)
   MAINTAINER:=John Crispin <blogic@openwrt.org>
   MENU:=1
 endef
index a0af1e5..74724eb 100644 (file)
@@ -22,7 +22,7 @@ define KernelPackage/ltq-vmmc
   SUBMENU:=Voice over IP
   TITLE:=TAPI LL driver for Voice Macro
   URL:=http://www.lantiq.com/
-  DEPENDS:=+kmod-ltq-tapi @(TARGET_lantiq_danube||TARGET_lantiq_falcon||TARGET_lantiq_falcon_stable)
+  DEPENDS:=+kmod-ltq-tapi @(TARGET_lantiq_danube||TARGET_lantiq_falcon)
   FILES:=$(PKG_BUILD_DIR)/src/drv_vmmc.ko
   AUTOLOAD:=$(call AutoLoad,25,drv_vmmc)
   MAINTAINER:=John Crispin <blogic@openwrt.org>
index d36036b..37d5d8c 100644 (file)
@@ -34,7 +34,7 @@ define Package/owsip-template
 endef
 
 Package/owsip-oss=$(call Package/owsip-template,oss,OSS,BROKEN)
-Package/owsip-ltq-tapi=$(call Package/owsip-template,ltq-tapi,Lantiq VMMC,@TARGET_lantiq +kmod-ltq-kpi2udp)
+Package/owsip-ltq-tapi=$(call Package/owsip-template,ltq-tapi,Lantiq VMMC,@(TARGET_lantiq_danube||TARGET_lantiq_falcon) +kmod-ltq-kpi2udp)
 
 define Package/owsip-$(BUILD_VARIANT)/description
        OpenWrt sip daemon - $(BUILD_VARIANT)