[ramips] initial support for Asus RT-N15
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 1 Sep 2009 19:34:27 +0000 (19:34 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 1 Sep 2009 19:34:27 +0000 (19:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17463 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/files/arch/mips/include/asm/mach-ralink/machine.h
target/linux/ramips/files/arch/mips/ralink/rt288x/Kconfig
target/linux/ramips/files/arch/mips/ralink/rt288x/Makefile
target/linux/ramips/files/arch/mips/ralink/rt288x/mach-rt-n15.c [new file with mode: 0644]
target/linux/ramips/rt288x/config-2.6.30

index 267d9f3..8bc3857 100644 (file)
@@ -10,6 +10,7 @@
 
 enum ramips_mach_type {
        RAMIPS_MACH_GENERIC,
+       RAMIPS_MACH_RT_N15,             /* Asus RT-N15 */
        RAMIPS_MACH_WHR_G300N,          /* Buffalo WHR-G300N */
 };
 
index bab02dd..3c7df5f 100644 (file)
@@ -2,6 +2,11 @@ if RALINK_RT288X
 
 menu "Ralink RT288x machine selection"
 
+config RT288X_MACH_RT_N15
+       bool "Asus RT-N15 board support"
+       default y
+       select RALINK_DEV_GPIO_LEDS
+
 endmenu
 
 endif
index fc06fa4..cac4187 100644 (file)
@@ -11,3 +11,5 @@
 obj-y  := prom.o irq.o setup.o rt288x.o devices.o
 
 obj-$(CONFIG_EARLY_PRINTK)             += early_printk.o
+
+obj-$(CONFIG_RT288X_MACH_RT_N15)       += mach-rt-n15.o
diff --git a/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-rt-n15.c b/target/linux/ramips/files/arch/mips/ralink/rt288x/mach-rt-n15.c
new file mode 100644 (file)
index 0000000..be5c815
--- /dev/null
@@ -0,0 +1,82 @@
+/*
+ *  Asus RT-N15 board support
+ *
+ *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <linux/init.h>
+#include <linux/platform_device.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+#include <linux/mtd/physmap.h>
+#include <linux/leds.h>
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ralink/machine.h>
+#include <asm/mach-ralink/dev_gpio_leds.h>
+
+#include "devices.h"
+
+#define RT_N15_GPIO_LED_POWER          11
+
+#ifdef CONFIG_MTD_PARTITIONS
+static struct mtd_partition rt_n15_partitions[] = {
+       {
+               .name   = "u-boot",
+               .offset = 0,
+               .size   = 0x030000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "u-boot-env",
+               .offset = 0x030000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "factory",
+               .offset = 0x040000,
+               .size   = 0x010000,
+               .mask_flags = MTD_WRITEABLE,
+       }, {
+               .name   = "kernel",
+               .offset = 0x050000,
+               .size   = 0x0b0000,
+       }, {
+               .name   = "rootfs",
+               .offset = 0x100000,
+               .size   = 0x300000,
+       }, {
+               .name   = "openwrt",
+               .offset = 0x050000,
+               .size   = 0x3b0000,
+       }
+};
+#endif /* CONFIG_MTD_PARTITIONS */
+
+static struct physmap_flash_data rt_n15_flash_data = {
+#ifdef CONFIG_MTD_PARTITIONS
+       .nr_parts       = ARRAY_SIZE(rt_n15_partitions),
+       .parts          = rt_n15_partitions,
+#endif
+};
+
+static struct gpio_led rt_n15_leds_gpio[] __initdata = {
+       {
+               .name           = "rt-n15:blue:power",
+               .gpio           = RT_N15_GPIO_LED_POWER,
+               .active_low     = 1,
+       }
+};
+
+static void __init rt_n15_init(void)
+{
+       rt288x_register_flash(0, &rt_n15_flash_data);
+
+       ramips_register_gpio_leds(-1, ARRAY_SIZE(rt_n15_leds_gpio),
+                                 rt_n15_leds_gpio);
+}
+
+MIPS_MACHINE(RAMIPS_MACH_RT_N15, "Asus RT-N15", rt_n15_init);
index 63afd63..0bab2d0 100644 (file)
@@ -117,6 +117,7 @@ CONFIG_PHYLIB=y
 # CONFIG_PROM_EMU is not set
 CONFIG_RALINK_RT288X=y
 # CONFIG_RALINK_RT305X is not set
+CONFIG_RT288X_MACH_RT_N15=y
 CONFIG_SCHED_OMIT_FRAME_POINTER=y
 # CONFIG_SCSI_DMA is not set
 # CONFIG_SERIAL_8250_EXTENDED is not set