ar71xx: create image for the TP-Link TL-WR740N v3
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 21 Sep 2011 11:47:40 +0000 (11:47 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 21 Sep 2011 11:47:40 +0000 (11:47 +0000)
Signed-off-by: Martin Raykov <martin.raykov@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28269 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/generic/profiles/tp-link.mk
target/linux/ar71xx/image/Makefile

index bc0bcd2..f5a7a24 100644 (file)
@@ -71,6 +71,19 @@ endef
 
 $(eval $(call Profile,TLWR740NV1))
 
+
+define Profile/TLWR740NV3
+       NAME:=TP-LINK TL-WR740N v3
+       PACKAGES:=
+endef
+
+define Profile/TLWR740NV3/Description
+       Package set optimized for the TP-LINK TL-WR740N v3.
+endef
+
+$(eval $(call Profile,TLWR740NV3))
+
+
 define Profile/TLWR841NV15
        NAME:=TP-LINK TL-WR841N v1.5
        PACKAGES:=
index abcf625..d808a1d 100644 (file)
@@ -591,6 +591,11 @@ define Image/Build/Profile/TLWR740NV1
        $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr740n-v1,$(tlwe740nv1_cmdline),TL-WR740Nv1)
 endef
 
+tlwe740nv3_cmdline=board=TL-WR741ND console=ttyS0,115200
+define Image/Build/Profile/TLWR740NV3
+       $(call Image/Build/Template/$(fs_64k)/$(1),TPLINK,tl-wr740n-v3,$(tlwe740nv3_cmdline),TL-WR740Nv3)
+endef
+
 tlwr841nv15_cmdline=board=TL-WR841N-v1.5 console=ttyS0,115200
 define Image/Build/Profile/TLWR841NV15
        $(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,$(tlwr841nv15_cmdline),TL-WR841Nv1.5)
@@ -703,6 +708,7 @@ define Image/Build/Profile/Default
        $(call Image/Build/Profile/TLWA901NDV2,$(1))
        $(call Image/Build/Profile/TLWR741NDV1,$(1))
        $(call Image/Build/Profile/TLWR740NV1,$(1))
+       $(call Image/Build/Profile/TLWR740NV3,$(1))
        $(call Image/Build/Profile/TLWR841NV15,$(1))
        $(call Image/Build/Profile/TLWR841NDV3,$(1))
        $(call Image/Build/Profile/TLWR841NDV5,$(1))