Remove packages when cleaning
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Mar 2005 14:35:58 +0000 (14:35 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 6 Mar 2005 14:35:58 +0000 (14:35 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@319 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/arptables/Makefile
openwrt/package/bridge/Makefile
openwrt/package/ebtables/Makefile
openwrt/package/iproute2/Makefile
openwrt/package/iptables/Makefile
openwrt/package/matrixssl/Makefile
openwrt/package/openssl/Makefile
openwrt/package/openvpn/Makefile

index 03c6322..3058fa1 100644 (file)
@@ -44,3 +44,4 @@ install: $(IPKG_STATE_DIR)/info/arptables.list
 
 clean:
        rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
index 4381b1d..708666c 100644 (file)
@@ -70,3 +70,4 @@ install: $(IPKG_STATE_DIR)/info/bridge.list
 
 clean:
        rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
index fd168a8..5bfbaa1 100644 (file)
@@ -44,3 +44,4 @@ install: $(IPKG_STATE_DIR)/info/ebtables.list
 
 clean:
        rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)
index ad2ba00..6c786ea 100644 (file)
@@ -91,3 +91,4 @@ install: $(INSTALL_TARGETS)
 
 clean:
        rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IP) $(PKG_TC)
index 67e4a2d..b0c1f77 100644 (file)
@@ -104,4 +104,4 @@ install: $(INSTALL_TARGETS)
 
 clean:
        rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPT) 
+       rm -f $(PKG_IPT) $(PKG_IPT_EXTRA) $(PKG_IP6T)
index 4775c12..2352742 100644 (file)
@@ -52,5 +52,5 @@ install: $(PKG_ZLIB) $(IPKG_STATE_DIR)/info/libmatrixssl.list
 clean:
        rm -rf $(PKG_BUILD_DIR)
        rm -f $(STAGING_DIR)/lib/libmatrixssl* $(STAGING_DIR)/include/matrixssl*
-       rm -f $(PACKAGE_DIR)/matrixssl\*.ipk
+       rm -f $(PKG_IPK)
 
index eb566c5..4d30be3 100644 (file)
@@ -72,5 +72,5 @@ clean:
        rm -rf $(PKG_BUILD_DIR)
        rm -f $(STAGING_DIR)/lib/libssl*
        rm -f $(STAGING_DIR)/lib/libcrypto*
-       rm -f $(PACKAGE_DIR)/$(PKG_NAME)\*.ipk
+       rm -f $(PKG_IPK)
 
index 94bee61..e9a9cf4 100644 (file)
@@ -70,3 +70,4 @@ install: $(IPKG_STATE_DIR)/info/openvpn.list
 
 clean:
        rm -rf $(PKG_BUILD_DIR)
+       rm -f $(PKG_IPK)