busybox: fix disabling /sbin/init and logread if procd is used as init
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Mar 2013 01:25:42 +0000 (01:25 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Mar 2013 01:25:42 +0000 (01:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36054 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/busybox/Makefile

index f4553c0..ed58fab 100644 (file)
@@ -62,7 +62,7 @@ endef
 define Build/Configure
        rm -f $(PKG_BUILD_DIR)/.configured*
        grep 'CONFIG_BUSYBOX_' $(TOPDIR)/.config | sed -e "s,\\(# \)\\?CONFIG_BUSYBOX_\\(.*\\),\\1\\2,g" > $(PKG_BUILD_DIR)/.config
-       yes '' | $(MAKE) -C $(PKG_BUILD_DIR) \
+       yes 'n' | $(MAKE) -C $(PKG_BUILD_DIR) \
                CC="$(TARGET_CC)" \
                CROSS_COMPILE="$(TARGET_CROSS)" \
                KBUILD_HAVE_NLS=no \
@@ -113,7 +113,6 @@ define Package/busybox/install
                $(INSTALL_BIN) ./files/$$$$tmp $(1)/etc/init.d/$$$$tmp; \
        done
        -rm -rf $(1)/lib64
-       $(if $(CONFIG_PROCD_INIT),rm -f $(1)/sbin/init $(1)/sbin/logread)
 endef
 
 $(eval $(call BuildPackage,busybox))