fix timestamp checks for build system paths which have '.svn' in their directory...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Apr 2010 22:21:15 +0000 (22:21 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 14 Apr 2010 22:21:15 +0000 (22:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20856 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/depends.mk
scripts/timestamp.pl

index 4c31eb3..65e9b25 100644 (file)
@@ -11,7 +11,7 @@
 #      3: tempfile for file listings
 #      4: find options
 
-DEP_FINDPARAMS := -x "*.svn*" -x ".*" -x "*.svn*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
+DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check"
 
 find_md5=find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
 
index 3bf0571..e24d814 100755 (executable)
@@ -14,7 +14,7 @@ sub get_ts($$) {
        my $ts = 0;
        my $fn = "";
        $path .= "/" if( -d $path);
-       open FIND, "find $path -type f -and -not -path \\*.svn\\* -and -not -path \\*CVS\\* $options 2>/dev/null |";
+       open FIND, "find $path -type f -and -not -path \\*/.svn\\* -and -not -path \\*CVS\\* $options 2>/dev/null |";
        while (<FIND>) {
                chomp;
                my $file = $_;