uboot-envtools: use new scripts from /lib/ to match boards
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Jun 2014 10:14:14 +0000 (10:14 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Jun 2014 10:14:14 +0000 (10:14 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@41340 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/imx6
package/boot/uboot-envtools/files/kirkwood

index dad971a..301a0e4 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2014.04
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2014.04
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index 66fceac..fac6436 100644 (file)
@@ -1,19 +1,20 @@
 #!/bin/sh
 #
 #!/bin/sh
 #
-# Copyright (C) 2013 OpenWrt.org
+# Copyright (C) 2013-2014 OpenWrt.org
 #
 
 [ -e /etc/config/ubootenv ] && exit 0
 
 touch /etc/config/ubootenv
 
 #
 
 [ -e /etc/config/ubootenv ] && exit 0
 
 touch /etc/config/ubootenv
 
+. /lib/imx6.sh
 . /lib/uboot-envtools.sh
 . /lib/functions.sh
 
 . /lib/uboot-envtools.sh
 . /lib/functions.sh
 
-board=$(cat /proc/device-tree/model)
+board=$(imx6_board_name)
 
 case "$board" in
 
 case "$board" in
-"Wandboard i.MX6 Dual Lite Board")
+"wandboard")
        ubootenv_add_uci_config "/dev/mmcblk0" "0x60000" "0x2000" "0x2000"
        ;;
 esac
        ubootenv_add_uci_config "/dev/mmcblk0" "0x60000" "0x2000" "0x2000"
        ;;
 esac
index 7856f3c..ef6c113 100644 (file)
@@ -7,13 +7,16 @@
 
 touch /etc/config/ubootenv
 
 
 touch /etc/config/ubootenv
 
+. /lib/kirkwood.sh
 . /lib/uboot-envtools.sh
 . /lib/functions.sh
 
 . /lib/uboot-envtools.sh
 . /lib/functions.sh
 
-case "`cat /proc/device-tree/model`" in
-"Cloud Engines Pogoplug E02" | \
-"Linksys EA4500" | \
-"RaidSonic ICY BOX IB-NAS62x0 (Rev B)")
+board=$(kirkwood_board_name)
+
+case "$board" in
+"ea4500" | \
+"ib62x0" | \
+"pogo_e02")
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x20000" "0x20000"
        ;;
 esac
        ubootenv_add_uci_config "/dev/mtd1" "0x0" "0x20000" "0x20000"
        ;;
 esac