Don't try to generate whr-g300n image if it's going to be more than 4M
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Apr 2014 21:21:44 +0000 (21:21 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 12 Apr 2014 21:21:44 +0000 (21:21 +0000)
Signed-off-by: Roman Yeryomin <roman@advem.lv>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40489 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ramips/image/Makefile

index c6a42ad..63f7425 100644 (file)
@@ -456,13 +456,15 @@ define BuildFirmware/WHRG300N/squashfs
        $(call BuildFirmware/Default4M/$(1),$(1),whr-g300n,WHR-G300N)
        # the following line has a bad argument 3 ... the old Makefile was already broken       
        $(call BuildFirmware/Buffalo,$(1),whr-g300n,whr-g300n)
-       ( \
-               echo -n -e "# Airstation FirmWare\nrun u_fw\nreset\n\n" | \
-                       dd bs=512 count=1 conv=sync; \
-               dd if=$(call sysupname,$(1),whr-g300n); \
-       ) > $(KDIR)/whr-g300n-tftp.tmp
-       buffalo-tftp -i $(KDIR)/whr-g300n-tftp.tmp \
-               -o $(call imgname,$(1),whr-g300n)-tftp.bin
+       if [ -e "$(call sysupname,$(1),$(2))" ]; then \
+               ( \
+                       echo -n -e "# Airstation FirmWare\nrun u_fw\nreset\n\n" | \
+                               dd bs=512 count=1 conv=sync; \
+                       dd if=$(call sysupname,$(1),whr-g300n); \
+               ) > $(KDIR)/whr-g300n-tftp.tmp && \
+               buffalo-tftp -i $(KDIR)/whr-g300n-tftp.tmp \
+                       -o $(call imgname,$(1),whr-g300n)-tftp.bin; \
+       fi
 endef
 BuildFirmware/WHRG300N/initramfs=$(call BuildFirmware/OF/initramfs,$(1),whr-g300n,WHR-G300N)
 Image/Build/Profile/WHRG300N=$(call BuildFirmware/WHRG300N/$(1),$(1))