package/base-files: change sysctl handling
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Mar 2013 18:43:30 +0000 (18:43 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 25 Mar 2013 18:43:30 +0000 (18:43 +0000)
Move /etc/init.d/sysctl to index 00 and add hotplug script that applies
interface specific sysctls for interfaces that only appear later - this
allows to reliably configure per-interface parameters in sysctl.conf, e.g.
to disable ipv6 autoconfig on a specific iface.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36129 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/hotplug.d/net/00-sysctl [new file with mode: 0644]
package/base-files/files/etc/init.d/sysctl

index fcc24e5..acd5e2e 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=136
+PKG_RELEASE:=137
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/hotplug.d/net/00-sysctl b/package/base-files/files/etc/hotplug.d/net/00-sysctl
new file mode 100644 (file)
index 0000000..5d9da8a
--- /dev/null
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+if [ -f /etc/sysctl.conf ] && [ "$ACTION" = add ]; then
+       sed -ne "/^[[:space:]]*net\..*\.$DEVICENAME\./p" /etc/sysctl.conf | \
+               sysctl -e -p - | logger -t sysctl
+fi
index 2397790..beeb79f 100755 (executable)
@@ -1,7 +1,7 @@
 #!/bin/sh /etc/rc.common
 # Copyright (C) 2006 OpenWrt.org 
 
-START=99
+START=0
 start() {
        [ -f /etc/sysctl.conf ] && sysctl -p -e >&-
 }