imx6: add default profile
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Oct 2013 00:33:49 +0000 (00:33 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 2 Oct 2013 00:33:49 +0000 (00:33 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38282 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/imx6/Makefile
target/linux/imx6/profiles/100-Generic.mk [new file with mode: 0644]

index b9b2062..3af424e 100644 (file)
@@ -20,7 +20,6 @@ include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:="zImage dtbs"
 
-DEFAULT_PACKAGES += \
-       kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy uboot-envtools
+DEFAULT_PACKAGES +=
 
 $(eval $(call BuildTarget))
diff --git a/target/linux/imx6/profiles/100-Generic.mk b/target/linux/imx6/profiles/100-Generic.mk
new file mode 100644 (file)
index 0000000..91ca369
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Generic
+  NAME:=Generic (default)
+  PACKAGES:= \
+       kmod-thermal-imx kmod-usb-chipidea kmod-usb-mxs-phy \
+       uboot-envtools
+endef
+
+define Profile/Generic/Description
+ Package set compatible with most Freescale i.MX 6 based boards.
+endef
+
+$(eval $(call Profile,Generic))