[kirkwood] Add different profiles for Sheevaplug and Dockstar
authorlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Aug 2010 21:16:00 +0000 (21:16 +0000)
committerlars <lars@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 29 Aug 2010 21:16:00 +0000 (21:16 +0000)
Thanks to Gerrit Visser

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22838 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/kirkwood/base-files-Dockstar/etc/config/network [new file with mode: 0644]
target/linux/kirkwood/base-files-Dockstar/etc/config/system [new file with mode: 0644]
target/linux/kirkwood/image/Makefile
target/linux/kirkwood/profiles/100-Sheevaplug.mk [new file with mode: 0644]
target/linux/kirkwood/profiles/200-Dockstar.mk [new file with mode: 0644]

diff --git a/target/linux/kirkwood/base-files-Dockstar/etc/config/network b/target/linux/kirkwood/base-files-Dockstar/etc/config/network
new file mode 100644 (file)
index 0000000..9fd44f1
--- /dev/null
@@ -0,0 +1,9 @@
+config 'interface' 'loopback'
+        option 'ifname' 'lo'
+        option 'proto' 'static'
+        option 'ipaddr' '127.0.0.1'
+        option 'netmask' '255.0.0.0'
+
+config 'interface' 'lan'
+        option 'ifname' 'eth0'
+        option 'proto' 'dhcp'
diff --git a/target/linux/kirkwood/base-files-Dockstar/etc/config/system b/target/linux/kirkwood/base-files-Dockstar/etc/config/system
new file mode 100644 (file)
index 0000000..4de2b9f
--- /dev/null
@@ -0,0 +1,16 @@
+# system file for Dockstar
+config system
+        option hostname OpenWrt
+        option timezone UTC
+
+config rdate
+        option interface        eth0
+config led
+        option 'sysfs' 'dockstar:green:health'
+        option 'trigger' 'none'
+        option 'default' '1'
+config led
+        option 'sysfs' 'dockstar:orange:misc'
+        option 'trigger' 'netdev'
+        option 'mode' 'tx rx'
+        option 'dev' 'eth0'
index 129ad95..c93be67 100644 (file)
@@ -21,12 +21,12 @@ endef
 define Image/Build
        $(if $(Image/Build/$(1)), \
                $(call Image/Build/$(1),$(1)), \
-               $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
+               $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img \
        )
 endef
 
 define Image/Build/jffs2-128k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(1).img \
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img \
                bs=2048 conv=sync
 endef
 
@@ -35,7 +35,7 @@ define Image/Build/squashfs
        ( \
                dd if=$(KDIR)/uImage bs=4096k conv=sync; \
                dd if=$(KDIR)/root.$(1) bs=128k conv=sync; \
-       ) > $(BIN_DIR)/$(IMG_PREFIX)-$(1).img
+       ) > $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-$(1).img
 endef
 
 $(eval $(call BuildImage))
diff --git a/target/linux/kirkwood/profiles/100-Sheevaplug.mk b/target/linux/kirkwood/profiles/100-Sheevaplug.mk
new file mode 100644 (file)
index 0000000..65008fe
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Sheevaplug
+  NAME:=Globalscale Sheevaplug
+  PACKAGES:=
+endef
+
+define Profile/Sheevaplug/Description
+        Globalscale Sheevaplug Profile
+endef
+
+$(eval $(call Profile,Sheevaplug))
diff --git a/target/linux/kirkwood/profiles/200-Dockstar.mk b/target/linux/kirkwood/profiles/200-Dockstar.mk
new file mode 100644 (file)
index 0000000..5b5d9cb
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Dockstar
+  NAME:=Seagate Dockstar
+  PACKAGES:=
+endef
+
+define Profile/Dockstar/Description
+        Seagate Dockstar Profile
+endef
+
+$(eval $(call Profile,Dockstar))