gettext-full: update to v0.19.4
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Jan 2015 14:51:29 +0000 (14:51 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Jan 2015 14:51:29 +0000 (14:51 +0000)
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43896 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/libs/gettext-full/Makefile
package/libs/gettext-full/patches/001-autotools.patch
package/libs/gettext-full/patches/001-no_examples_and_tests.patch
package/libs/gettext-full/patches/120-uclibc-nolocale.patch

index 2399f0f..1f8c2c8 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2013 OpenWrt.org
+# Copyright (C) 2006-2015 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gettext-full
-PKG_VERSION:=0.18.2.1
+PKG_VERSION:=0.19.4
 PKG_RELEASE:=1
 
-PKG_SOURCE:=gettext-$(PKG_VERSION).tar.gz
+PKG_SOURCE:=gettext-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=@GNU/gettext
-PKG_MD5SUM:=034c8103b14654ebd300fadac44d6f14
+PKG_MD5SUM:=997c9070354eff5517115feaea6038f0
 PKG_BUILD_DIR:=$(BUILD_DIR)/gettext-$(PKG_VERSION)
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/gettext-$(PKG_VERSION)
 
index 9b0abc8..ecbb030 100644 (file)
@@ -1,35 +1,24 @@
 --- a/gettext-runtime/man/Makefile.am
 +++ b/gettext-runtime/man/Makefile.am
-@@ -159,8 +159,7 @@ bind_textdomain_codeset.3.html: bind_tex
-       $(MAN2HTML) $(srcdir)/bind_textdomain_codeset.3.in | sed -e '/CreationDate:/d' > t-$@
-       mv t-$@ $@
+@@ -171,8 +171,7 @@ textdomain.3.html: textdomain.3.in
+ bindtextdomain.3.html: bindtextdomain.3.in
+ bind_textdomain_codeset.3.html: bind_textdomain_codeset.3.in
  
 -install-html-local:
--      $(mkdir_p) $(DESTDIR)$(htmldir)
+-      $(MKDIR_P) $(DESTDIR)$(htmldir)
 +install-html: installdirs-html
        for file in $(man_HTML); do \
          if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
          $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
 --- a/gettext-tools/man/Makefile.am
 +++ b/gettext-tools/man/Makefile.am
-@@ -186,8 +186,7 @@ autopoint.1.html: autopoint.1
-       $(MAN2HTML) `if test -f autopoint.1; then echo .; else echo $(srcdir); fi`/autopoint.1 | sed -e '/CreationDate:/d' > t-$@
-       mv t-$@ $@
+@@ -153,8 +153,7 @@ recode-sr-latin.1.html: recode-sr-latin.
+ gettextize.1.html: gettextize.1
+ autopoint.1.html: autopoint.1
  
 -install-html-local:
--      $(mkdir_p) $(DESTDIR)$(htmldir)
+-      $(MKDIR_P) $(DESTDIR)$(htmldir)
 +install-html: installdirs-html
        for file in $(man_HTML); do \
          if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
          $(INSTALL_DATA) $$dir/$$file $(DESTDIR)$(htmldir)/$$file; \
---- a/gettext-runtime/intl/Makefile.in
-+++ b/gettext-runtime/intl/Makefile.in
-@@ -17,7 +17,7 @@
- PACKAGE = @PACKAGE@
- VERSION = @VERSION@
--SHELL = /bin/sh
-+SHELL = @SHELL@
- srcdir = @srcdir@
- top_srcdir = @top_srcdir@
index 3660413..373b4a1 100644 (file)
@@ -1,22 +1,22 @@
---- a/gettext-runtime/Makefile.in
-+++ b/gettext-runtime/Makefile.in
-@@ -251,7 +251,7 @@ ETAGS = etags
- CTAGS = ctags
- CSCOPE = cscope
- DIST_SUBDIRS = doc intl intl-java intl-csharp gnulib-lib libasprintf \
--      src po man m4 tests
-+      src po man m4
- DISTFILES = $(DIST_COMMON) $(DIST_SOURCES) $(TEXINFOS) $(EXTRA_DIST)
- distdir = $(PACKAGE)-$(VERSION)
- top_distdir = $(distdir)
---- a/gettext-tools/Makefile.in
-+++ b/gettext-tools/Makefile.in
-@@ -1503,7 +1503,7 @@ top_builddir = @top_builddir@
- top_srcdir = @top_srcdir@
+--- a/gettext-runtime/Makefile.am
++++ b/gettext-runtime/Makefile.am
+@@ -28,7 +28,7 @@ SUBDIR_libasprintf = libasprintf
+ else
+ SUBDIR_libasprintf =
+ endif
+-SUBDIRS = doc intl intl-java intl-csharp gnulib-lib $(SUBDIR_libasprintf) src po man m4 tests
++SUBDIRS = intl intl-java intl-csharp gnulib-lib $(SUBDIR_libasprintf) src po m4
+ EXTRA_DIST = BUGS
+--- a/gettext-tools/Makefile.am
++++ b/gettext-tools/Makefile.am
+@@ -19,7 +19,7 @@
  AUTOMAKE_OPTIONS = 1.5 gnu no-dependencies
  ACLOCAL_AMFLAGS = -I m4 -I ../gettext-runtime/m4 -I ../m4 -I gnulib-m4 -I libgrep/gnulib-m4 -I libgettextpo/gnulib-m4
--SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
-+SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4
  
- # Allow users to use "gnulib-tool --update".
+-SUBDIRS = doc intl gnulib-lib libgrep src libgettextpo po projects styles misc man m4 tests gnulib-tests examples
++SUBDIRS = intl gnulib-lib libgrep src libgettextpo po projects styles misc m4
  
+ EXTRA_DIST = misc/DISCLAIM
+ MOSTLYCLEANFILES = core *.stackdump
index 81eda14..51d523f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/gettext-runtime/intl/localename.c
 +++ b/gettext-runtime/intl/localename.c
-@@ -2679,7 +2679,7 @@ gl_locale_name_posix (int category, cons
+@@ -2779,7 +2779,7 @@ gl_locale_name_posix (int category, cons
  {
    /* Use the POSIX methods of looking to 'LC_ALL', 'LC_xxx', and 'LANG'.
       On some systems this can be done by the 'setlocale' function itself.  */