turn the IXP4xx microcode check into a prereq check so that the error message is...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Jan 2007 18:45:54 +0000 (18:45 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 20 Jan 2007 18:45:54 +0000 (18:45 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6148 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ixp4xx-2.6/image/Makefile
target/linux/ixp4xx-2.6/image/npe-ucode/Makefile

index cbbb29b..bb33aff 100644 (file)
@@ -51,3 +51,17 @@ define Image/Build/jffs2-128k
 endef
 
 $(eval $(call BuildImage))
+
+UCODEFILE:=IPL_ixp400NpeLibrary-2_3.zip
+
+define Require/npe-ucode
+       [ -f $(DL_DIR)/$(UCODEFILE) ]
+endef
+
+$(eval $(call Require,npe-ucode, \
+       You must manually download $(UCODEFILE) from \\\
+       http://www.intel.com/design/network/products/npfamily/ixp400_current.htm \\\
+       and put it in $(DL_DIR). \\\
+       You will need to agree to the Intel Public License to do so - please do read it! \
+))
+       
index 7dc476b..1f61570 100644 (file)
@@ -14,7 +14,6 @@ PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE:=IPL_ixp400NpeLibrary-2_3.zip
-PKG_SOURCE_URL:=http://www.intel.com/design/network/products/npfamily/ixp400_current.htm
 PKG_UNPACK:=unzip -d $(PKG_BUILD_DIR)/ $(DL_DIR)/$(PKG_SOURCE)
 
 include $(INCLUDE_DIR)/unpack.mk
@@ -32,12 +31,6 @@ $(PKG_BUILD_DIR)/NPE-B: $(PKG_BUILD_DIR)/.prepared
          $(HOSTCC) -Wall IxNpeMicrocode.c -o IxNpeMicrocode ; \
          ./IxNpeMicrocode -be )
 
-$(DL_DIR)/$(PKG_SOURCE):
-       mkdir -p $(DL_DIR)
-       echo "You must manually download $(PKG_SOURCE) from $(PKG_SOURCE_URL) and put it in $(DL_DIR)."
-       echo "You will need to agree to the Intel Public License to do so - please do read it!"
-       false
-
 download: $(DL_DIR)/$(PKG_SOURCE)
 prepare: $(PKG_BUILD_DIR)/.prepared
 compile: $(PKG_BUILD_DIR)/NPE-B