[package] base-files/busybox: move ntpd init script from base-files to busybox
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 17 Jul 2013 22:24:45 +0000 (22:24 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 17 Jul 2013 22:24:45 +0000 (22:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37383 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/init.d/sysntpd [deleted file]
package/utils/busybox/Makefile
package/utils/busybox/files/ntp [new file with mode: 0755]

index fa2081f..3bdb0a8 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=141
+PKG_RELEASE:=142
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
diff --git a/package/base-files/files/etc/init.d/sysntpd b/package/base-files/files/etc/init.d/sysntpd
deleted file mode 100755 (executable)
index c40ee76..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-#!/bin/sh /etc/rc.common
-# Copyright (C) 2011 OpenWrt.org
-
-START=98
-
-USE_PROCD=1
-PROG=/usr/sbin/ntpd
-SERVICE_PID_FILE=/var/run/sysntpd.pid
-
-start_service() {
-       local peers
-       local args="-n"
-       local enable_server
-
-       config_load system
-       config_get peers ntp server
-       config_get_bool enable_server ntp enable_server 0
-
-       [ $enable_server -eq 0 -a -z "$peers" ] && return
-
-       procd_open_instance
-       procd_set_param command "$PROG" -n
-        [ $enable_server -ne 0 ] && procd_append_param command -l
-       [ -n "$peers" ] && {
-               local peer
-               for peer in $peers; do
-                       procd_append_param command -p $peer
-               done
-       }
-       procd_close_instance
-}
index aed6dde..0b2778f 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=busybox
 PKG_VERSION:=1.19.4
-PKG_RELEASE:=6
+PKG_RELEASE:=7
 PKG_FLAGS:=essential
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -37,6 +37,7 @@ endif
 
 init-y :=
 init-$(CONFIG_BUSYBOX_CONFIG_CROND) += cron
+init-$(CONFIG_BUSYBOX_CONFIG_NTPD) += ntp
 init-$(CONFIG_BUSYBOX_CONFIG_TELNETD) += telnet
 
 define Package/busybox
diff --git a/package/utils/busybox/files/ntp b/package/utils/busybox/files/ntp
new file mode 100755 (executable)
index 0000000..c40ee76
--- /dev/null
@@ -0,0 +1,31 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2011 OpenWrt.org
+
+START=98
+
+USE_PROCD=1
+PROG=/usr/sbin/ntpd
+SERVICE_PID_FILE=/var/run/sysntpd.pid
+
+start_service() {
+       local peers
+       local args="-n"
+       local enable_server
+
+       config_load system
+       config_get peers ntp server
+       config_get_bool enable_server ntp enable_server 0
+
+       [ $enable_server -eq 0 -a -z "$peers" ] && return
+
+       procd_open_instance
+       procd_set_param command "$PROG" -n
+        [ $enable_server -ne 0 ] && procd_append_param command -l
+       [ -n "$peers" ] && {
+               local peer
+               for peer in $peers; do
+                       procd_append_param command -p $peer
+               done
+       }
+       procd_close_instance
+}