[ppc44x]: upgrade to 3.0
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Jul 2011 20:44:08 +0000 (20:44 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Jul 2011 20:44:08 +0000 (20:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@27738 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ppc44x/Makefile
target/linux/ppc44x/config-default
target/linux/ppc44x/patches/005-canyonlands_remove_nonexisting_uarts.patch [deleted file]
target/linux/ppc44x/patches/100-openwrt_flashmap.patch

index b13261a..95f1ee6 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.32.33
+LINUX_VERSION:=3.0
 
 include $(INCLUDE_DIR)/target.mk
 
index fffead2..bec21b5 100644 (file)
@@ -25,6 +25,7 @@ CONFIG_BITREVERSE=y
 # CONFIG_BOOKE_WDT is not set
 CONFIG_BOOKE=y
 CONFIG_BOUNCE=y
+# CONFIG_BLUESTONE is not set
 CONFIG_CANYONLANDS=y
 CONFIG_CC_OPTIMIZE_FOR_SIZE=y
 CONFIG_CLASSIC_RCU=y
diff --git a/target/linux/ppc44x/patches/005-canyonlands_remove_nonexisting_uarts.patch b/target/linux/ppc44x/patches/005-canyonlands_remove_nonexisting_uarts.patch
deleted file mode 100644 (file)
index 5a240de..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/arch/powerpc/boot/dts/canyonlands.dts
-+++ b/arch/powerpc/boot/dts/canyonlands.dts
-@@ -262,28 +262,6 @@
-                               interrupts = <0x1 0x4>;
-                       };
--                      UART2: serial@ef600500 {
--                              device_type = "serial";
--                              compatible = "ns16550";
--                              reg = <0xef600500 0x00000008>;
--                              virtual-reg = <0xef600500>;
--                              clock-frequency = <0>; /* Filled in by U-Boot */
--                              current-speed = <0>; /* Filled in by U-Boot */
--                              interrupt-parent = <&UIC1>;
--                              interrupts = <0x1d 0x4>;
--                      };
--
--                      UART3: serial@ef600600 {
--                              device_type = "serial";
--                              compatible = "ns16550";
--                              reg = <0xef600600 0x00000008>;
--                              virtual-reg = <0xef600600>;
--                              clock-frequency = <0>; /* Filled in by U-Boot */
--                              current-speed = <0>; /* Filled in by U-Boot */
--                              interrupt-parent = <&UIC1>;
--                              interrupts = <0x1e 0x4>;
--                      };
--
-                       IIC0: i2c@ef600700 {
-                               compatible = "ibm,iic-460ex", "ibm,iic";
-                               reg = <0xef600700 0x00000014>;
index 592e64c..225831a 100644 (file)
@@ -25,7 +25,7 @@
                                                label = "env";
 --- a/arch/powerpc/boot/dts/canyonlands.dts
 +++ b/arch/powerpc/boot/dts/canyonlands.dts
-@@ -187,24 +187,12 @@
+@@ -217,24 +217,12 @@
                                        #address-cells = <1>;
                                        #size-cells = <1>;
                                        partition@0 {