sunxi: respect CONFIG_TARGET_IMAGES_GZIP
authorwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 Aug 2015 15:10:14 +0000 (15:10 +0000)
committerwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 15 Aug 2015 15:10:14 +0000 (15:10 +0000)
Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@46608 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/sunxi/image/Makefile

index 10d2200..5a5c98a 100644 (file)
@@ -45,6 +45,10 @@ define Image/Build/SDCard
                $(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
                $(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
                $(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) \
                $(KDIR)/uboot-sunxi-$(PROFILE)-u-boot-with-spl.bin
+
+  ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+       gzip -f9n $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img
+  endif
 endef
 
 define Image/Build/Profile/A10-OLinuXino-Lime
 endef
 
 define Image/Build/Profile/A10-OLinuXino-Lime