x86: fix condition in base-files.mk
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Oct 2013 11:45:33 +0000 (11:45 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Oct 2013 11:45:33 +0000 (11:45 +0000)
TARGET_x86_generic_Soekris48xx is not defined,
CONFIG_TARGET_x86_generic_Soekris48xx is

This changes makes it possible to override the network config for soekris net48xx
and net45xx targets.

Signed-off-by: Bruno Randolf <br1@einfach.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38450 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/x86/base-files.mk

index 889f944..6c6e6f1 100644 (file)
@@ -1,4 +1,4 @@
-ifneq ($(TARGET_x86_generic_Soekris48xx)$(TARGET_x86_generic_Soekris45xx),)
+ifneq ($(CONFIG_TARGET_x86_generic_Soekris48xx)$(CONFIG_TARGET_x86_generic_Soekris45xx),)
 define Package/base-files/install-target
        rm -f $(1)/etc/config/network
 endef
 define Package/base-files/install-target
        rm -f $(1)/etc/config/network
 endef