uhttpd: add option for mbedtls
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Jan 2016 10:06:18 +0000 (10:06 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 19 Jan 2016 10:06:18 +0000 (10:06 +0000)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@48343 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/uhttpd/Makefile

index 2b05abf..da5572b 100644 (file)
@@ -54,6 +54,7 @@ define Package/uhttpd-mod-tls
   TITLE+= (TLS plugin)
   DEPENDS:=uhttpd \
        +PACKAGE_uhttpd-mod-tls_polarssl:libustream-polarssl \
+       +PACKAGE_uhttpd-mod-tls_mbedtls:libustream-mbedtls \
        +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl \
        +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
 endef
@@ -68,6 +69,9 @@ define Package/uhttpd-mod-tls/config
     prompt "TLS Provider"
     default PACKAGE_uhttpd-mod-tls_polarssl
 
+    config PACKAGE_uhttpd-mod-tls_mbedtls
+      bool "mbedTLS"
+
     config PACKAGE_uhttpd-mod-tls_polarssl
       bool "PolarSSL"