ath10k-firmware: update firmware version for QCA988X (again)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Nov 2015 21:33:01 +0000 (21:33 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Nov 2015 21:33:01 +0000 (21:33 +0000)
Updates the ath10-firmware release to current git and updates the
QCA988X firmware in use to version 10.2.4.70.12-2 which appears to
actually fix the stability problems when using a Nexus 5X phone as
per issue #20854. Also updates the Makefile for a change in the
location of the board.bin file for QCA988X in the source repository.

Signed-off-by: Robert Hancock <hancockrwd@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47469 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/firmware/ath10k-firmware/Makefile

index 3cd48c2..31cf4b9 100644 (file)
@@ -8,8 +8,8 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ath10k-firmware
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ath10k-firmware
-PKG_SOURCE_VERSION:=7d14e337ad25c0ef3e78fc47eac336697ca612e8
-PKG_VERSION:=2014-10-28-$(PKG_SOURCE_VERSION)
+PKG_SOURCE_VERSION:=69f955c3dd95d97c7c30960aa5c9852c80b85cc3
+PKG_VERSION:=2014-11-13-$(PKG_SOURCE_VERSION)
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
@@ -54,10 +54,10 @@ endef
 define Package/ath10k-firmware-qca988x/install
        $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA988X/hw2.0
        $(INSTALL_DATA) \
 define Package/ath10k-firmware-qca988x/install
        $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA988X/hw2.0
        $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/ath10k/QCA988X/hw2.0/board.bin \
+               $(PKG_BUILD_DIR)/QCA988X/board.bin \
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/
        $(INSTALL_DATA) \
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/
        $(INSTALL_DATA) \
-               $(PKG_BUILD_DIR)/QCA988X/10.2.4/firmware-5.bin_10.2.4.70.10-2 \
+               $(PKG_BUILD_DIR)/QCA988X/10.2.4/firmware-5.bin_10.2.4.70.12-2 \
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
 endef
 
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
 endef