build: allow AutoLoad and AutoProbe to specify modules not included in the package
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 Nov 2014 20:16:50 +0000 (20:16 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 19 Nov 2014 20:16:50 +0000 (20:16 +0000)
On out-of-tree modules depending on other out-of-tree modules from a
different tree, module dependencies are not filled properly.
This change helps with adding those dependencies in the AutoLoad call

Signed-off-by: Felix Fietkau <nbd@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43323 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk

index ae2dcc3..28c8cf8 100644 (file)
@@ -84,10 +84,8 @@ define ModuleAutoLoad
                boot="$$$$$$$$2"; \
                shift 2; \
                for mod in $$$$$$$$mods; do \
-                       if [ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ]; then \
-                               mkdir -p $(2)/etc/modules.d; \
-                               echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$(1); \
-                       fi; \
+                       mkdir -p $(2)/etc/modules.d; \
+                       echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$(1); \
                done; \
                if [ -e $(2)/etc/modules.d/$(1) ]; then \
                        if [ "$$$$$$$$boot" = "1" ]; then \
@@ -103,10 +101,8 @@ define ModuleAutoLoad
                boot="$$$$$$$$3"; \
                shift 3; \
                for mod in $$$$$$$$mods; do \
-                       if [ -e $(2)/$(MODULES_SUBDIR)/$$$$$$$$mod.ko ]; then \
-                               mkdir -p $(2)/etc/modules.d; \
-                               echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
-                       fi; \
+                       mkdir -p $(2)/etc/modules.d; \
+                       echo "$$$$$$$$mod" >> $(2)/etc/modules.d/$$$$$$$$priority-$(1); \
                done; \
                if [ -e $(2)/etc/modules.d/$$$$$$$$priority-$(1) ]; then \
                        if [ "$$$$$$$$boot" = "1" ]; then \