package/grub: add a prereq check for 32 bits host development files when building...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Aug 2010 09:12:46 +0000 (09:12 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 16 Aug 2010 09:12:46 +0000 (09:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22667 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/grub/Makefile

index 5fd2a23..426b9c3 100644 (file)
@@ -88,5 +88,16 @@ define Package/grub/install
        $(CP) $(PKG_INSTALL_DIR)/usr/sbin/* $(1)/usr/sbin/
 endef
 
+ifeq ($(HOST_ARCH),x86_64)
+  define Require/working-gcc-m32
+       echo 'int main(int argc, char **argv) { return 0; }' | \
+               gcc -x c -o $(TMP_DIR)/a.out - -m32 -lc
+  endef
+endif
+
+$(eval $(call Require,working-gcc-m32, \
+       Please install 32 bits development files. (gcc-multilib on Debian/Ubuntu, gcc.i686 and libgcc.i686 on CentOS/Fedora/RHEL) \
+))
+
 $(eval $(call HostBuild))
 $(eval $(call BuildPackage,grub))