add ipkg/conffiles, add Id tag to the Makefile, standardize.
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Dec 2005 13:19:49 +0000 (13:19 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Dec 2005 13:19:49 +0000 (13:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2738 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/ipcad/Config.in [changed mode: 0755->0644]
openwrt/package/ipcad/Makefile [changed mode: 0755->0644]
openwrt/package/ipcad/ipkg/ipcad.conffiles [new file with mode: 0644]
openwrt/package/ipcad/ipkg/ipcad.control [changed mode: 0755->0644]
openwrt/package/ipcad/patches/01-honor_cppflags.patch [new file with mode: 0644]

old mode 100755 (executable)
new mode 100644 (file)
index c38731f..fa5d0e9
@@ -1,10 +1,12 @@
 config BR2_PACKAGE_IPCAD
-        tristate "ipcad............................. listens for traffic on the specified interfaces"
-               default m if CONFIG_DEVEL
-               select BR2_PACKAGE_LIBPCAP
-               help
-                       This daemon listens for traffic on the specified interfaces.
-                       It has the built-in RSH and NetFlow engines to allow exporting
-                       the accounting data the same way as Cisco routers do.
-                       
-                       http://lionet.info/ipcad/
+       prompt "ipcad............................. listens for traffic on the specified interfaces"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBPCAP
+       help
+         This daemon listens for traffic on the specified interfaces.
+         It has the built-in RSH and NetFlow engines to allow exporting
+         the accounting data the same way as Cisco routers do.
+         
+         http://lionet.info/ipcad/
+
old mode 100755 (executable)
new mode 100644 (file)
index 749500f..870362a
@@ -1,14 +1,17 @@
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipcad
 PKG_VERSION:=3.7
 PKG_RELEASE:=1
 PKG_MD5SUM:=34c542c99593dfe9d5b408deffcfe70e
+
 PKG_SOURCE_URL:=@SF/ipcad
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
 
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(TOPDIR)/package/rules.mk
@@ -17,37 +20,51 @@ $(eval $(call PKG_template,IPCAD,$(PKG_NAME),$(PKG_VERSION)-$(PKG_RELEASE),$(ARC
 
 $(PKG_BUILD_DIR)/.configured:
        (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
-                $(TARGET_CONFIGURE_OPTS) \
-                CFLAGS="$(TARGET_CFLAGS) -I$(STAGING_DIR)/usr/include -L$(STAGING_DIR)/usr/lib" \
-                ./configure \
-                --target=$(GNU_TARGET_NAME) \
-                --host=$(GNU_TARGET_NAME) \
-                --build=$(GNU_HOST_NAME) \
-                --prefix=/usr \
-                --exec-prefix=/usr \
-                --bindir=/usr/bin \
-                --sbindir=/usr/sbin \
-                --libexecdir=/usr/lib \
-                --sysconfdir=/etc \
-                --datadir=/usr/share \
-                --localstatedir=/var \
-                --mandir=/usr/man \
-               --mandir=/usr/man \
-                --infodir=/usr/info \
-                --program-prefix="" \
-               --with-gnu-ld \
-               --with-psrc=pcap \
-               --with-pcap-include=$(STAGING_DIR)/usr/include \
-               --with-pcap-libraries=$(STAGING_DIR)/usr/lib \
+               touch cfglex.c cslex.c; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --disable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
+                       --with-psrc=pcap \
+                       --with-pcap-include="$(STAGING_DIR)/usr/include" \
+                       --with-pcap-libraries="$(STAGING_DIR)/usr/lib" \
        );
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
-       $(MAKE) STAGING_DIR=$(STAGING_DIR) DESTDIR=$(PKG_INSTALL_DIR) -C $(PKG_BUILD_DIR) install
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR=$(PKG_INSTALL_DIR) \
+               all install
        touch $@
 
 $(IPKG_IPCAD):
-       mkdir -p $(IDIR_IPCAD)
-       cp -fpR $(PKG_INSTALL_DIR)/* $(IDIR_IPCAD)/
+       install -d -m0755 $(IDIR_IPCAD)/etc
+       cp -fpR $(PKG_INSTALL_DIR)/etc/ipcad.conf $(IDIR_IPCAD)/etc/
+       install -d -m0755 $(IDIR_IPCAD)/usr/bin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/bin/ipcad $(IDIR_IPCAD)/usr/bin/
        $(RSTRIP) $(IDIR_IPCAD)
        $(IPKG_BUILD) $(IDIR_IPCAD) $(PACKAGE_DIR)
diff --git a/openwrt/package/ipcad/ipkg/ipcad.conffiles b/openwrt/package/ipcad/ipkg/ipcad.conffiles
new file mode 100644 (file)
index 0000000..f6843d8
--- /dev/null
@@ -0,0 +1 @@
+/etc/ipcad.conf
old mode 100755 (executable)
new mode 100644 (file)
diff --git a/openwrt/package/ipcad/patches/01-honor_cppflags.patch b/openwrt/package/ipcad/patches/01-honor_cppflags.patch
new file mode 100644 (file)
index 0000000..55f9888
--- /dev/null
@@ -0,0 +1,11 @@
+diff -ruN ipcad-3.7-old/Makefile.in ipcad-3.7-new/Makefile.in
+--- ipcad-3.7-old/Makefile.in  2005-11-21 05:41:07.000000000 +0100
++++ ipcad-3.7-new/Makefile.in  2005-12-20 10:27:07.000000000 +0100
+@@ -9,6 +9,7 @@
+ LDFLAGS+= @LDFLAGS@
+ LIBS+= @LIBS@
+ CFLAGS+= @CFLAGS@ @DEFS@ -W -Wall
++CPPFLAGS+= @CPPFLAGS@
+ CPPFLAGS+=-DIPCAD_VERSION=\"@IPCAD_VERSION@\"
+ CPPFLAGS+=-DCONFIG_FILE=\"${sysconfdir}/ipcad.conf\"
+ CPPFLAGS+=@DEFS@ -D_REENTRANT -D_THREAD_SAFE