fix the broken build for brcm 2.4, idea from nbd
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 10 Sep 2005 16:57:20 +0000 (16:57 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 10 Sep 2005 16:57:20 +0000 (16:57 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1887 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Makefile
package/nvram/Makefile

index cdc592b..86a84a4 100644 (file)
@@ -372,6 +372,7 @@ $(STAMP_DIR):
                TARGET_DIR="$(TARGET_DIR)" \
                IPKG_CONF="$(IPKG_CONF)" \
                BOARD="$(BOARD)" \
+               KERNEL="$(KERNEL)" \
                install
 
 %-rebuild: 
index 337f722..f7312fe 100644 (file)
@@ -10,13 +10,11 @@ PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
 include $(TOPDIR)/package/rules.mk
 
 # does not depend on menuconfig
-ifneq ($(BOARD),brcm)
+ifneq ($(BOARD)-$(KERNEL),brcm-2.4)
 BR2_PACKAGE_NVRAM:=m
 else
-ifeq ($(LINUX_VERSION),2.4.30)
 BR2_PACKAGE_NVRAM:=y
 endif
-endif
 
 $(eval $(call PKG_template,NVRAM,nvram,$(PKG_RELEASE),$(ARCH)))