iproute2: fix compile with uClibc-ng
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 30 Oct 2015 15:20:41 +0000 (15:20 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 30 Oct 2015 15:20:41 +0000 (15:20 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@47291 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iproute2/Makefile

index 23834df..f5b5f4e 100644 (file)
@@ -84,6 +84,9 @@ endif
 ifdef CONFIG_USE_MUSL
   TARGET_CFLAGS += -DHAVE_SETNS
 endif
 ifdef CONFIG_USE_MUSL
   TARGET_CFLAGS += -DHAVE_SETNS
 endif
+ifdef CONFIG_UCLIBC_USE_VERSION_NG
+  TARGET_CFLAGS += -DHAVE_SETNS
+endif
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections
 
 
 TARGET_CFLAGS += -ffunction-sections -fdata-sections