add ipsec-tools package
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Dec 2005 10:02:08 +0000 (10:02 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Dec 2005 10:02:08 +0000 (10:02 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2607 3c298f89-4303-0410-b956-a3cf2f4a3e73

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/ipsec-tools/Config.in [new file with mode: 0644]
openwrt/package/ipsec-tools/Makefile [new file with mode: 0644]
openwrt/package/ipsec-tools/ipkg/ipsec-tools.conffiles [new file with mode: 0644]
openwrt/package/ipsec-tools/ipkg/ipsec-tools.control [new file with mode: 0644]
openwrt/package/ipsec-tools/patches/01-no_libfl.patch [new file with mode: 0644]
openwrt/package/ipsec-tools/patches/02-configure_cppflags_typo.patch [new file with mode: 0644]

index 7766a63..934c759 100644 (file)
@@ -71,6 +71,7 @@ source "package/hostapd/Config.in"
 source "package/htpdate/Config.in"
 source "package/iproute2/Config.in"
 source "package/iperf/Config.in"
+source "package/ipsec-tools/Config.in"
 source "package/ipset/Config.in"
 source "package/iptables-snmp/Config.in"
 source "package/iptraf/Config.in"
index 9b814c1..7203d9f 100644 (file)
@@ -62,6 +62,7 @@ package-$(BR2_PACKAGE_ID3LIB) += id3lib
 package-$(BR2_PACKAGE_IPERF) += iperf
 package-$(BR2_PACKAGE_IPKG) += ipkg
 package-$(BR2_COMPILE_IPROUTE2) += iproute2
+package-$(BR2_PACKAGE_IPSEC_TOOLS) += ipsec-tools
 package-$(BR2_PACKAGE_IPSET) += ipset
 package-$(BR2_COMPILE_IPTABLES) += iptables
 package-$(BR2_PACKAGE_IPTABLES_SNMP) += iptables-snmp
diff --git a/openwrt/package/ipsec-tools/Config.in b/openwrt/package/ipsec-tools/Config.in
new file mode 100644 (file)
index 0000000..161c927
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_IPSEC_TOOLS
+       prompt "ipsec-tools....................... IPsec management tools"
+       tristate
+       default n
+       help
+         IPsec management tools
+         
+         http://ipsec-tools.sourceforge.net/
+
diff --git a/openwrt/package/ipsec-tools/Makefile b/openwrt/package/ipsec-tools/Makefile
new file mode 100644 (file)
index 0000000..b05df8d
--- /dev/null
@@ -0,0 +1,85 @@
+# $Id: Makefile 2409 2005-11-10 08:08:12Z nico $
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=ipsec-tools
+PKG_VERSION:=0.6.3
+PKG_RELEASE:=1
+PKG_MD5SUM:=8070f90402919d8d313c32c2ee465b2f
+
+PKG_SOURCE_URL:=@SF/ipsec-tools
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_CAT:=bzcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,IPSEC_TOOLS,ipsec-tools,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
+               touch configure.ac; \
+               touch aclocal.m4; \
+               touch Makefile.in; \
+               touch config.h.in; \
+               touch configure; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+                       --enable-shared \
+                       --enable-static \
+                       --disable-rpath \
+                       --with-gnu-ld \
+                       --with-kernel-headers="$(LINUX_DIR)/include" \
+                       --without-readline \
+                       --with-openssl="$(STAGING_DIR)/usr" \
+                       --without-libradius \
+                       --without-libpam \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               CFLAGS="$(TARGET_CFLAGS) -Wall" \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+
+$(IPKG_IPSEC_TOOLS):
+       install -d -m0755 $(IDIR_IPSEC_TOOLS)/etc
+       cp -fpR $(PKG_BUILD_DIR)/src/racoon/samples/racoon.conf $(IDIR_IPSEC_TOOLS)/etc/
+       install -d -m0755 $(IDIR_IPSEC_TOOLS)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libipsec.so.* $(IDIR_IPSEC_TOOLS)/usr/lib/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/libracoon.so.* $(IDIR_IPSEC_TOOLS)/usr/lib/
+       install -d -m0755 $(IDIR_IPSEC_TOOLS)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/plainrsa-gen $(IDIR_IPSEC_TOOLS)/usr/sbin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/racoon $(IDIR_IPSEC_TOOLS)/usr/sbin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/racoonctl $(IDIR_IPSEC_TOOLS)/usr/sbin/
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/setkey $(IDIR_IPSEC_TOOLS)/usr/sbin/
+       $(RSTRIP) $(IDIR_IPSEC_TOOLS)
+       $(IPKG_BUILD) $(IDIR_IPSEC_TOOLS) $(PACKAGE_DIR)
diff --git a/openwrt/package/ipsec-tools/ipkg/ipsec-tools.conffiles b/openwrt/package/ipsec-tools/ipkg/ipsec-tools.conffiles
new file mode 100644 (file)
index 0000000..4340454
--- /dev/null
@@ -0,0 +1 @@
+/etc/racoon.conf
diff --git a/openwrt/package/ipsec-tools/ipkg/ipsec-tools.control b/openwrt/package/ipsec-tools/ipkg/ipsec-tools.control
new file mode 100644 (file)
index 0000000..36f8a9c
--- /dev/null
@@ -0,0 +1,4 @@
+Package: ipsec-tools
+Priority: optional
+Section: net
+Description: IPsec management tools
diff --git a/openwrt/package/ipsec-tools/patches/01-no_libfl.patch b/openwrt/package/ipsec-tools/patches/01-no_libfl.patch
new file mode 100644 (file)
index 0000000..c842e22
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN ipsec-tools-0.6.3-old/src/racoon/cftoken.l ipsec-tools-0.6.3-new/src/racoon/cftoken.l
+--- ipsec-tools-0.6.3-old/src/racoon/cftoken.l 2005-11-06 18:18:26.000000000 +0100
++++ ipsec-tools-0.6.3-new/src/racoon/cftoken.l 2005-12-09 01:27:27.000000000 +0100
+@@ -105,6 +105,8 @@
+ static int incstackp = 0;
+ static int yy_first_time = 1;
++
++int yywrap(void) { return 1; }
+ %}
+ /* common seciton */
+diff -ruN ipsec-tools-0.6.3-old/src/setkey/token.l ipsec-tools-0.6.3-new/src/setkey/token.l
+--- ipsec-tools-0.6.3-old/src/setkey/token.l   2005-06-29 15:01:30.000000000 +0200
++++ ipsec-tools-0.6.3-new/src/setkey/token.l   2005-12-09 01:27:31.000000000 +0100
+@@ -84,6 +84,8 @@
+ #ifndef SADB_X_EALG_AESCTR
+ #define SADB_X_EALG_AESCTR    (-1)
+ #endif
++
++int yywrap(void) { return 1; }
+ %}
+ /* common section */
diff --git a/openwrt/package/ipsec-tools/patches/02-configure_cppflags_typo.patch b/openwrt/package/ipsec-tools/patches/02-configure_cppflags_typo.patch
new file mode 100644 (file)
index 0000000..f725ebd
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ruN ipsec-tools-0.6.3-old/configure.ac ipsec-tools-0.6.3-new/configure.ac
+--- ipsec-tools-0.6.3-old/configure.ac 2005-11-21 12:11:41.000000000 +0100
++++ ipsec-tools-0.6.3-new/configure.ac 2005-12-09 02:09:06.000000000 +0100
+@@ -180,7 +180,7 @@
+ if test "x$crypto_dir" != "x"; then
+       LIBS="$LIBS -L${crypto_dir}/lib"
+-      CPPFLAGS="-I${crypto_dir}/include $CPPLAGS"
++      CPPFLAGS="-I${crypto_dir}/include $CPPFLAGS"
+ fi
+ AC_MSG_CHECKING(openssl version)
+diff -ruN ipsec-tools-0.6.3-old/configure ipsec-tools-0.6.3-new/configure
+--- ipsec-tools-0.6.3-old/configure    2005-11-21 12:15:12.000000000 +0100
++++ ipsec-tools-0.6.3-new/configure    2005-12-09 02:09:13.000000000 +0100
+@@ -23680,7 +23680,7 @@
+ if test "x$crypto_dir" != "x"; then
+       LIBS="$LIBS -L${crypto_dir}/lib"
+-      CPPFLAGS="-I${crypto_dir}/include $CPPLAGS"
++      CPPFLAGS="-I${crypto_dir}/include $CPPFLAGS"
+ fi
+ echo "$as_me:$LINENO: checking openssl version" >&5
+ echo $ECHO_N "checking openssl version... $ECHO_C" >&6