brcm47xx: BGMAC - Adjust AutoLoad number to be prior to switch modules
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Feb 2013 16:27:33 +0000 (16:27 +0000)
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 16 Feb 2013 16:27:33 +0000 (16:27 +0000)
Adjust the "AutoLoad" number for the BGMAC module to be prior
to the switch modules.  This probably isn't real important as
the modules are loaded in the correct order by preinit anyway.

Signed-off-by: Nathan Hintz <nlhintz@hotmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35625 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm47xx/modules.mk

index 2ea637d..458c1ea 100644 (file)
@@ -43,7 +43,7 @@ define KernelPackage/bgmac
   DEPENDS:=@TARGET_brcm47xx
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   FILES:=$(LINUX_DIR)/drivers/net/ethernet/broadcom/bgmac.ko
-  AUTOLOAD:=$(call AutoLoad,50,bgmac)
+  AUTOLOAD:=$(call AutoLoad,19,bgmac)
 endef
 
 define KernelPackage/bgmac/description