fix more issues with libnl-tiny and eglibc
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 May 2009 16:13:46 +0000 (16:13 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 4 May 2009 16:13:46 +0000 (16:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15592 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/crda/Makefile
package/hostapd/Makefile
package/iw/Makefile

index 6585117..e53db3d 100644 (file)
@@ -51,6 +51,7 @@ endef
 
 TARGET_CPPFLAGS := \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
+       -D_GNU_SOURCE \
        $(TARGET_CPPFLAGS)
 
 MAKE_FLAGS += \
index bd873b9..6d0b18b 100644 (file)
@@ -98,7 +98,8 @@ TARGET_CPPFLAGS := \
        $(TARGET_CPPFLAGS) \
        -I$(STAGING_DIR)/usr/include/madwifi \
        -I$(STAGING_DIR)/usr/include/mac80211 \
-       -DCONFIG_LIBNL20
+       -DCONFIG_LIBNL20 \
+       -D_GNU_SOURCE
 
 define Build/CompileTarget
        CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \
index 9187b55..fb10f10 100644 (file)
@@ -37,7 +37,8 @@ TARGET_CPPFLAGS:= \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
        -I$(STAGING_DIR)/usr/include/mac80211 \
        $(TARGET_CPPFLAGS) \
-       -DCONFIG_LIBNL20
+       -DCONFIG_LIBNL20 \
+       -D_GNU_SOURCE
 
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CPPFLAGS) $(TARGET_CFLAGS)" \