more fixes for rstrip.sh and kernel modules - fixes #1301
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Feb 2007 16:24:34 +0000 (16:24 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 9 Feb 2007 16:24:34 +0000 (16:24 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6280 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk
scripts/rstrip.sh

index b63fcf3..a6188f4 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -87,8 +87,9 @@ TARGET_CONFIGURE_OPTS:= \
 
 # strip an entire directory
 RSTRIP:= \
+  NM="$(TARGET_CROSS)nm" \
   STRIP="$(STRIP)" \
-  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment -w -K '__mod*'" \
+  STRIP_KMOD="$(TARGET_CROSS)strip --strip-unneeded --remove-section=.comment" \
   $(SCRIPT_DIR)/rstrip.sh
 
 # where to build (and put) .ipk packages
index 252522b..6dd44f2 100755 (executable)
@@ -6,6 +6,23 @@
 # See /LICENSE for more information.
 #
 
+find_modparams() {
+       FILE="$1"
+       $NM "$FILE" | awk '
+BEGIN {
+       FS=" "
+}
+($3 ~ /^__module_parm_/) && ($3 !~ /^__module_parm_desc/) {
+       gsub(/__module_parm_/, "", $3)
+       printf "-K " $3 " "
+}
+($2 ~ /r/) && ($3 ~ /__param_/) {
+       gsub(/__param_/, "", $3)
+       printf "-K " $3 " "
+}
+'
+}
+
 
 SELF=${0##*/}
 
@@ -28,9 +45,11 @@ find $TARGETS -type f -a -exec file {} \; | \
   IFS=":"
   while read F S; do
     echo "$SELF: $F:$S"
-       [ "${F##*\.}" = "o" -o "${F##*\.}" = "ko" ] && \
-               eval "$STRIP_KMOD $F" || \
+       [ "${F##*\.}" = "o" -o "${F##*\.}" = "ko" ] && {
+               eval "$STRIP_KMOD -w -K '__param*' -K '__mod*' $(find_modparams "$F")$F"
+       } || {
                eval "$STRIP $F"
+       }
   done
   true
 )