[package] iproute2: workaround compile issues with gcc 4.8.x
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 16 May 2013 00:04:48 +0000 (00:04 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 16 May 2013 00:04:48 +0000 (00:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36642 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iproute2/Makefile
package/network/utils/iproute2/patches/000-warnings.patch [new file with mode: 0644]
package/network/utils/iproute2/patches/008-no_netem.patch
package/network/utils/iproute2/patches/110-extra-ccopts.patch

index 8e25f86..ff80df4 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=iproute2
 PKG_VERSION:=3.9.0
 
 PKG_NAME:=iproute2
 PKG_VERSION:=3.9.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://kernel.org/pub/linux/utils/net/iproute2/
diff --git a/package/network/utils/iproute2/patches/000-warnings.patch b/package/network/utils/iproute2/patches/000-warnings.patch
new file mode 100644 (file)
index 0000000..8f07c38
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/Makefile
++++ b/Makefile
+@@ -30,8 +30,7 @@ CC = gcc
+ HOSTCC = gcc
+ DEFINES += -D_GNU_SOURCE
+ CCOPTS = -O2
+-WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
+-WFLAGS += -Wmissing-declarations -Wold-style-definition
++WFLAGS := -Wall -Wstrict-prototypes
+ CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
+ YACCFLAGS = -d -t -v
index 165ce0c..78baead 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
 --- a/Makefile
 +++ b/Makefile
-@@ -36,7 +36,7 @@ WFLAGS += -Wmissing-declarations -Wold-s
+@@ -35,7 +35,7 @@ WFLAGS := -Wall -Wstrict-prototypes
  CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
  YACCFLAGS = -d -t -v
  
  CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)
  YACCFLAGS = -d -t -v
  
index af38fe1..71ec957 100644 (file)
@@ -6,6 +6,6 @@
  DEFINES += -D_GNU_SOURCE
 -CCOPTS = -O2
 +CCOPTS = -O2 $(EXTRA_CCOPTS)
  DEFINES += -D_GNU_SOURCE
 -CCOPTS = -O2
 +CCOPTS = -O2 $(EXTRA_CCOPTS)
- WFLAGS := -Wall -Wstrict-prototypes -Werror -Wmissing-prototypes
- WFLAGS += -Wmissing-declarations -Wold-style-definition
+ WFLAGS := -Wall -Wstrict-prototypes
  
  
+ CFLAGS = $(WFLAGS) $(CCOPTS) -I../include $(DEFINES)