fix prereqs
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Jul 2006 11:43:48 +0000 (11:43 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 22 Jul 2006 11:43:48 +0000 (11:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4203 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/prereq.mk

index 6642ce4..cbd26be 100644 (file)
@@ -29,7 +29,7 @@ define Require
 
     prereq-$(1): $(TMP_DIR) FORCE
                echo -n "Checking '$(1)'... "
-               if $(NO_TRACE_MAKE) -f $(INCLUDE_DIR)/prereq.mk check-$(1) >/dev/null 2>/dev/null; then \
+               if $(MAKE) -f $(INCLUDE_DIR)/prereq.mk check-$(1) >/dev/null 2>/dev/null; then \
                        echo 'ok.'; \
                else \
                        echo 'failed.'; \
@@ -59,7 +59,7 @@ define Require/working-make
        echo 'e0 = $$$$(foreach s,foobar,$$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
        echo 'e1 = $$$$(foreach s,foobar, $$$$(eval $$$$s:))' >> $(TMP_DIR)/check.mk
        echo 'test: $$$$(strip $$$$(e0)) $$$$(strip $$$$(e1))' >> $(TMP_DIR)/check.mk
-       $(NO_TRACE_MAKE) -f $(TMP_DIR)/check.mk
+       $(MAKE) -f $(TMP_DIR)/check.mk
 endef
 
 $(eval $(call Require,working-make, \