[package] acx-mac80211: support loading different firmwares
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Jan 2011 21:49:24 +0000 (21:49 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 27 Jan 2011 21:49:24 +0000 (21:49 +0000)
Signed-off-by: Alexey Torkhov <atorkhov@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@25167 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/acx-mac80211/Makefile

index 775e678..41761bf 100644 (file)
@@ -27,6 +27,37 @@ define KernelPackage/acx-mac80211
   DEPENDS:=@PCI_SUPPORT||TARGET_ar7 +kmod-mac80211
   FILES:=$(PKG_BUILD_DIR)/acx-mac80211.ko
   AUTOLOAD:=$(call AutoLoad,50,acx-mac80211)
+  MENU:=1
+endef
+
+define KernelPackage/acx-mac80211/config
+       menu "Configuration"
+               depends on PACKAGE_kmod-acx-mac80211
+
+       choice
+               prompt "acx firmware version"
+               default ACX_DEFAULT if !TARGET_adm5120
+               default ACX_1_2_1_34 if TARGET_adm5120
+               help
+                 This option allows you to select the version of the acx firmware.
+
+       config ACX_DEFAULT
+               bool "Default"
+               help
+                 Default firmware for ACX devices.
+
+                 If unsure, select this.
+
+       config ACX_1_2_1_34
+               bool "1.2.1_34"
+               help
+                 1.2.1_34 firmware for ACX devices. Works with Zyxel P-334WT.
+
+                 If unsure, select the "default" firmware.
+
+       endchoice
+
+       endmenu
 endef
 
 define KernelPackage/acx-mac80211/description
@@ -37,20 +68,31 @@ endef
 C16_FW:=tiacx111c16
 C19_FW:=tiacx111c19
 
-define Download/tiacx111c16
-  FILE:=$(C16_FW)
-  URL:=http://teknoraver.net/software/acx-mac80211/
-  MD5SUM:=7026826460376f6b174f9225bd7781b9
-endef
-$(eval $(call Download,tiacx111c16))
-
-define Download/tiacx111c19
-  FILE:=$(C19_FW)
-  URL:=http://ipkg.k1k2.de/files/
-  MD5SUM:=a1fa9681e297b4e36e257090fc12265a
-endef
-$(eval $(call Download,tiacx111c19))
+ifeq ($(CONFIG_ACX_DEFAULT),y)
+  define Download/tiacx111c16
+       FILE:=$(C16_FW)
+       URL:=http://teknoraver.net/software/acx-mac80211/
+       MD5SUM:=7026826460376f6b174f9225bd7781b9
+  endef
+  $(eval $(call Download,tiacx111c16))
+
+  define Download/tiacx111c19
+       FILE:=$(C19_FW)
+       URL:=http://ipkg.k1k2.de/files/
+       MD5SUM:=a1fa9681e297b4e36e257090fc12265a
+  endef
+  $(eval $(call Download,tiacx111c19))
+endif
 
+ifeq ($(CONFIG_ACX_1_2_1_34),y)
+  define Download/tiacx111c16
+       FILE:=$(C16_FW)_1.2.1_34
+#      URL:=http://acx100.erley.org/fw/acx111_1.2.1.34/
+       URL:=http://sites.google.com/site/atorkhov/files/
+       MD5SUM:=fcd07de4b25e1d2aaf3b78b27c5b7ee9
+  endef
+  $(eval $(call Download,tiacx111c16))
+endif
 
 PKG_EXTRA_KCONFIG:= \
        CONFIG_ACX_MAC80211=m \
@@ -86,8 +128,13 @@ endef
 
 define KernelPackage/acx-mac80211/install
        $(INSTALL_DIR) $(1)/lib/firmware
+ifeq ($(CONFIG_ACX_DEFAULT),y)
        $(INSTALL_DATA) $(DL_DIR)/$(C16_FW) $(1)/lib/firmware/
        $(INSTALL_DATA) $(DL_DIR)/$(C19_FW) $(1)/lib/firmware/
+endif
+ifeq ($(CONFIG_ACX_1_2_1_34),y)
+       $(INSTALL_DATA) $(DL_DIR)/$(C16_FW)_1.2.1_34 $(1)/lib/firmware/$(C16_FW)
+endif
 endef
 
 $(eval $(call KernelPackage,acx-mac80211))