util-linux-dmesg: Add missing install section
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 26 Oct 2014 16:57:27 +0000 (16:57 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 26 Oct 2014 16:57:27 +0000 (16:57 +0000)
Package util-linux-dmesg is broken (at least) in Barrier Breaker git repo
as you can select it within menuconfig, it will compile (as a part of
util-linux) but it will not install as install section is missing from
package Makefile.

Signed-off-by: Tomasz Wasiak <tjwasiak@gmail.com>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@43069 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/utils/util-linux/Makefile

index 1490767..7feafbf 100644 (file)
@@ -152,6 +152,7 @@ endef
 define Package/dmesg
 $(call Package/util-linux/Default)
   TITLE:=print or control the kernel ring buffer
+  DEPENDS:= +librt
 endef
 
 define Package/dmesg/description
@@ -438,6 +439,11 @@ define Package/cfdisk/install
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/cfdisk $(1)/usr/sbin/
 endef
 
+define Package/dmesg/install
+       $(INSTALL_DIR) $(1)/usr/sbin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/dmesg $(1)/usr/sbin/
+endef
+
 define Package/fdisk/install
        $(INSTALL_DIR) $(1)/usr/sbin
        $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/fdisk $(1)/usr/sbin/