add a swap-utils subpackage,
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Oct 2005 14:28:28 +0000 (14:28 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 8 Oct 2005 14:28:28 +0000 (14:28 +0000)
fix ipkg/control fields,
add cvs Id tag.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2075 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/util-linux/Config.in
package/util-linux/Makefile
package/util-linux/ipkg/fdisk.control
package/util-linux/ipkg/swap-utils.control [new file with mode: 0644]

index b10b272..ed62b7c 100644 (file)
@@ -13,3 +13,17 @@ config BR2_PACKAGE_FDISK
          http://www.kernel.org/pub/linux/utils/util-linux/
          
 
          http://www.kernel.org/pub/linux/utils/util-linux/
          
 
+config BR2_PACKAGE_SWAP_UTILS
+       tristate "swap-utils - Swap space management utilities"
+       default m if CONFIG_DEVEL
+       select BR2_COMPILE_UTIL_LINUX
+       help
+         A collection of tools to manage swap space :
+         
+           * mkswap
+           * swapon
+           * swapoff
+         
+         http://www.kernel.org/pub/linux/utils/util-linux/
+         
+
index 30a4398..d2cf96e 100644 (file)
@@ -1,3 +1,5 @@
+# $Id$
+
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fdisk
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fdisk
@@ -17,6 +19,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,FDISK,fdisk,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,FDISK,fdisk,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,SWAP_UTILS,swap-utils,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        (cd $(PKG_BUILD_DIR); \
 
 $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
        (cd $(PKG_BUILD_DIR); \
@@ -30,10 +33,11 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
 $(PKG_BUILD_DIR)/.built:
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
 $(PKG_BUILD_DIR)/.built:
        rm -rf $(PKG_INSTALL_DIR)
        mkdir -p $(PKG_INSTALL_DIR)
-       $(MAKE) -C $(PKG_BUILD_DIR)/fdisk \
+       $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                OPT="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                $(TARGET_CONFIGURE_OPTS) \
                OPT="$(TARGET_CFLAGS)" \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               INSTALLSUID="install -m 4755" \
                all install
        touch $@
 
                all install
        touch $@
 
@@ -43,6 +47,13 @@ $(IPKG_FDISK):
        $(RSTRIP) $(IDIR_FDISK)
        $(IPKG_BUILD) $(IDIR_FDISK) $(PACKAGE_DIR)
 
        $(RSTRIP) $(IDIR_FDISK)
        $(IPKG_BUILD) $(IDIR_FDISK) $(PACKAGE_DIR)
 
+$(IPKG_SWAP_UTILS):
+       install -d -m0755 $(IDIR_SWAP_UTILS)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/sbin/mkswap $(IDIR_SWAP_UTILS)/usr/sbin/
+       cp -fpR $(PKG_INSTALL_DIR)/sbin/swap{on,off} $(IDIR_SWAP_UTILS)/usr/sbin/
+       $(RSTRIP) $(IDIR_SWAP_UTILS)
+       $(IPKG_BUILD) $(IDIR_SWAP_UTILS) $(PACKAGE_DIR)
+
 mostlyclean:
        -$(MAKE) -C $(PKG_BUILD_DIR) clean
        rm -f $(PKG_BUILD_DIR)/.built
 mostlyclean:
        -$(MAKE) -C $(PKG_BUILD_DIR) clean
        rm -f $(PKG_BUILD_DIR)/.built
index 30f37b4..9eea615 100644 (file)
@@ -1,6 +1,7 @@
 Package: fdisk
 Priority: optional
 Package: fdisk
 Priority: optional
-Section: sys
-Maintainer: Philipp Kewisch <openwrt@kewis.ch>
-Source: ftp://ftp.kernel.org/pub/linux/utils/util-linux/util-linux-2.1.2r.tar.gz
-Description: Util-linux is a suite of essential utilities for any Linux system. This is the fdisk component of util-linux. Note however that this release is not stripped in any way.
+Section: admin
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>, Philipp Kewisch <openwrt@kewis.ch>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/util-linux/
+Depends:
+Description: A partition table manipulation utility
diff --git a/package/util-linux/ipkg/swap-utils.control b/package/util-linux/ipkg/swap-utils.control
new file mode 100644 (file)
index 0000000..6c4459d
--- /dev/null
@@ -0,0 +1,7 @@
+Package: swap-utils
+Priority: optional
+Section: admin
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/util-linux/
+Depends:
+Description: Swap space management utilities