ar71xx: image: remove too big files in the CatFiles macro
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Sep 2013 20:14:22 +0000 (20:14 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 22 Sep 2013 20:14:22 +0000 (20:14 +0000)
Also improve the warning message.

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38125 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index bb6f612..65ddabe 100644 (file)
@@ -115,7 +115,8 @@ define CatFiles
                esac; \
                ( dd if=$(1) bs=$$$${bs} conv=sync;  cat $(3) ) > $(5); \
                if [ `stat -c%s $(5)` -gt $(4) ]; then \
-                       echo "Warning: $(1) is too big" >&2; \
+                       echo "Warning: $(5) is too big (> $(4) bytes)" >&2; \
+                       rm -f $(5); \
                fi; \
        else if [ $(2) -gt 262144 -a `stat -c%s "$(1)"` -gt $(2) ]; then \
                echo "Warning: $(1) is too big" >&2; \