[brcm47xx] deselect wpad-mini in wl profile instead of adding it to all other profile...
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Jun 2010 13:44:19 +0000 (13:44 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 20 Jun 2010 13:44:19 +0000 (13:44 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@21852 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm47xx/Makefile
target/linux/brcm47xx/profiles/100-Broadcom-b43.mk
target/linux/brcm47xx/profiles/101-Broadcom-wl.mk
target/linux/brcm47xx/profiles/105-Atheros.mk
target/linux/brcm47xx/profiles/WL500GPv1-ATH.mk

index eae5ca3..56c87e4 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=squashfs usb pcmcia
 LINUX_VERSION:=2.6.32.14
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
+DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
 
 define Target/Description
        Build firmware images for Broadcom based routers
index 1242180..df8d37b 100644 (file)
@@ -6,8 +6,8 @@
 #
 
 define Profile/Broadcom-b43
-  NAME:=Broadcom BCM43xx WiFi - "b43" driver (default)
-  PACKAGES:=wpad-mini kmod-b43 kmod-b43legacy
+  NAME:=Broadcom BCM43xx WiFi (b43, default)
+  PACKAGES:=kmod-b43 kmod-b43legacy
 endef
 
 define Profile/Broadcom-b43/Description
index 4cfb089..d67298c 100644 (file)
@@ -6,8 +6,8 @@
 #
 
 define Profile/Broadcom-wl
-  NAME:=Broadcom BCM43xx WiFi - "wl" driver (proprietary)
-  PACKAGES:=kmod-brcm-wl wlc nas
+  NAME:=Broadcom BCM43xx WiFi (wl, proprietary)
+  PACKAGES:=-wpad-mini kmod-brcm-wl wlc nas
 endef
 
 define Profile/Broadcom-wl/Description
index 889f4bc..46046a1 100644 (file)
@@ -6,7 +6,7 @@
 #
 
 define Profile/Atheros
-  NAME:=Atheros WiFi
+  NAME:=Atheros WiFi (madwifi)
   PACKAGES:=kmod-madwifi
 endef
 
index 2dea0d5..bf86303 100644 (file)
@@ -6,7 +6,7 @@
 #
 
 define Profile/WL500GPv1
-  NAME:=ASUS WL-500g Premium v1 (Atheros WiFi)
+  NAME:=ASUS WL-500g Premium v1 (Atheros WiFi using madwifi)
   PACKAGES:=kmod-madwifi kmod-usb-core kmod-usb-uhci kmod-usb2
 endef