add setpwc package
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 12 Sep 2005 03:43:09 +0000 (03:43 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 12 Sep 2005 03:43:09 +0000 (03:43 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1908 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/Config.in
package/Makefile
package/setpwc/Config.in [new file with mode: 0644]
package/setpwc/Makefile [new file with mode: 0644]
package/setpwc/ipkg/setpwc.control [new file with mode: 0644]

index 58c24c6..995c52d 100644 (file)
@@ -174,6 +174,7 @@ comment "Multimedia ---"
 source "package/gmediaserver/Config.in"
 source "package/mt-daapd/Config.in"
 source "package/mpd/Config.in"
+source "package/setpwc/Config.in"
 
 comment "Serial communications & terminal emulation ---"
 source "package/microcom/Config.in"
index 2cb00f2..f1da9de 100644 (file)
@@ -146,6 +146,7 @@ package-$(BR2_COMPILE_SAMBA) += samba
 package-$(BR2_PACKAGE_SCREEN) += screen
 package-$(BR2_PACKAGE_SDK) += sdk
 package-$(BR2_PACKAGE_SER) += ser
+package-$(BR2_PACKAGE_SETPWC) += setpwc
 package-$(BR2_PACKAGE_SETSERIAL) += setserial
 package-$(BR2_PACKAGE_SHAT) += shat
 package-$(BR2_PACKAGE_SHFS) += shfs
diff --git a/package/setpwc/Config.in b/package/setpwc/Config.in
new file mode 100644 (file)
index 0000000..dcf1346
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_SETPWC
+       tristate "setpwc - Philips (and compatibles) WebCams (PWC) control utility"
+#      default m if CONFIG_DEVEL
+       default n
+       help
+         Philips (and compatibles) WebCams (PWC) control utility.
+         
+         http://www.vanheusden.com/setpwc/
+         
diff --git a/package/setpwc/Makefile b/package/setpwc/Makefile
new file mode 100644 (file)
index 0000000..dbd41c5
--- /dev/null
@@ -0,0 +1,32 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=setpwc
+PKG_VERSION:=1.0
+PKG_RELEASE:=1
+PKG_MD5SUM:=a125d76f630c4aab940df5912f161965
+
+PKG_SOURCE_URL:=http://www.vanheusden.com/setpwc/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,SETPWC,setpwc,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured:
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       $(TARGET_CC) $(TARGET_CFLAGS) -DVERSION=\"$(PKG_VERSION)\" -o $(PKG_BUILD_DIR)/setpwc $(PKG_BUILD_DIR)/setpwc.c 
+       touch $@
+
+$(IPKG_SETPWC):
+       install -d -m0755 $(IDIR_SETPWC)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/setpwc $(IDIR_SETPWC)/usr/bin/
+       $(RSTRIP) $(IDIR_SETPWC)
+       $(IPKG_BUILD) $(IDIR_SETPWC) $(PACKAGE_DIR)
diff --git a/package/setpwc/ipkg/setpwc.control b/package/setpwc/ipkg/setpwc.control
new file mode 100644 (file)
index 0000000..ad14825
--- /dev/null
@@ -0,0 +1,8 @@
+Package: setpwc
+Priority: optional
+Section: admin
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/setpwc/
+Description: Philips (and compatibles) WebCams (PWC) control utility