iptables: use -ffunction-sections, -fdata-sections and --gc-sections
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 May 2013 10:15:10 +0000 (10:15 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 21 May 2013 10:15:10 +0000 (10:15 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@36680 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/utils/iptables/Makefile

index fb7aef9..a0ea7f7 100644 (file)
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
 PKG_VERSION:=1.4.18
 
 PKG_NAME:=iptables
 PKG_VERSION:=1.4.18
-PKG_RELEASE:=3
+PKG_RELEASE:=4
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
@@ -342,7 +342,11 @@ TARGET_CPPFLAGS := \
 
 TARGET_CFLAGS += \
        -I$(PKG_BUILD_DIR)/include \
 
 TARGET_CFLAGS += \
        -I$(PKG_BUILD_DIR)/include \
-       -I$(LINUX_DIR)/user_headers/include
+       -I$(LINUX_DIR)/user_headers/include \
+       -ffunction-sections -fdata-sections
+
+TARGET_LDFLAGS += \
+       -Wl,--gc-sections
 
 CONFIGURE_ARGS += \
        --enable-shared \
 
 CONFIGURE_ARGS += \
        --enable-shared \