linux-atm: fix offline postinstall for br2684ctl
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Oct 2012 19:53:44 +0000 (19:53 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Oct 2012 19:53:44 +0000 (19:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@33900 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/linux-atm/Makefile
package/linux-atm/files/br2684ctl

index f829b70..7b5cf1f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -10,7 +10,7 @@ include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=linux-atm
 PKG_VERSION:=2.5.2
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/$(PKG_NAME)
index cd53f04..30b1a44 100755 (executable)
@@ -1,14 +1,13 @@
 #!/bin/sh /etc/rc.common
 
-
-. /lib/functions/network.sh
-
 START=50
 
 SERVICE_DAEMONIZE=1
 SERVICE_WRITE_PID=1
 
 start_daemon() {
+       . /lib/functions/network.sh
+
        local cfg="$1"
 
        local atmdev