map: add sleep work-around for lw4o6 race-condition
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Jun 2015 21:18:55 +0000 (21:18 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 9 Jun 2015 21:18:55 +0000 (21:18 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45936 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/map/Makefile
package/network/ipv6/map/files/map.sh

index 89d34de..3757ed6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=map
 PKG_VERSION:=4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 PKG_LICENSE:=GPL-2.0
 
 include $(INCLUDE_DIR)/package.mk
index 5e37aa2..98a493d 100755 (executable)
@@ -39,6 +39,9 @@ proto_map_setup() {
 
        ( proto_add_host_dependency "$cfg" "::" "$tunlink" )
 
+       # fixme: handle RA/DHCPv6 address race for LW
+       [ "$type" = lw4o6 ] && sleep 5
+
        if [ -z "$rule" ]; then
                rule="type=$type,ipv6prefix=$ip6prefix,prefix6len=$ip6prefixlen,ipv4prefix=$ipaddr,prefix4len=$ip4prefixlen"
                [ -n "$psid" ] && rule="$rule,psid=$psid"