small compile fix for gcc 3.4.3
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Apr 2005 15:59:13 +0000 (15:59 +0000)
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 1 Apr 2005 15:59:13 +0000 (15:59 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@503 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/ebtables/Makefile
package/ebtables/patches/gcc3.4-ebtables_c.patch [new file with mode: 0644]

index 3f0b467..809caf3 100644 (file)
@@ -19,6 +19,7 @@ $(DL_DIR)/$(PKG_SOURCE):
 
 $(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
        $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       $(PATCH) $(PKG_BUILD_DIR) ./patches
        touch $(PKG_BUILD_DIR)/.unpacked
 
 $(PKG_BUILD_DIR)/ebtables: $(PKG_BUILD_DIR)/.unpacked
diff --git a/package/ebtables/patches/gcc3.4-ebtables_c.patch b/package/ebtables/patches/gcc3.4-ebtables_c.patch
new file mode 100644 (file)
index 0000000..1973ea5
--- /dev/null
@@ -0,0 +1,10 @@
+--- ebtables-v2.0.6/ebtables.c 2003-11-02 19:22:56.000000000 +0100
++++ ebtables-patch/ebtables.c  2005-03-29 08:03:09.734707134 +0200
+@@ -1171,6 +1171,7 @@
+                       continue;
+               return i;
+ letscontinue:
++      {};
+       }
+       return -1;
+ }