brcm63xx: Add DT support for 96338W
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 Oct 2014 12:25:27 +0000 (12:25 +0000)
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 2 Oct 2014 12:25:27 +0000 (12:25 +0000)
Renamed of_board_id to convention.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Jonas Gorski <jogo@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@42734 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/brcm63xx/dts/bcm96338W.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.14/370-bcm63xx-add-of_board_ids-for-all-supported-boards.patch
target/linux/brcm63xx/profiles/01-generic.mk

diff --git a/target/linux/brcm63xx/dts/bcm96338W.dts b/target/linux/brcm63xx/dts/bcm96338W.dts
new file mode 100644 (file)
index 0000000..1609541
--- /dev/null
@@ -0,0 +1,8 @@
+/dts-v1/;
+
+/include/ "bcm6338.dtsi"
+
+/ {
+       model = "Broadcom BCM96338W reference board";
+       compatible = "brcm,bcm96338w", "brcm,bcm6338";
+};
index c7e7978..957ea9b 100755 (executable)
@@ -234,7 +234,6 @@ endef
 define Image/Build
        dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/$(IMG_PREFIX)-root.$(1) bs=128k conv=sync
        # Various routers
-       $(call Image/Build/CFE,$(1),6338W,6338,6338W-generic,,)
        $(call Image/Build/CFE,$(1),96358VW,6358,96358VW-generic)
        $(call Image/Build/CFE,$(1),96358VW2,6358,96358VW2-generic)
        $(call Image/Build/CFE,$(1),96368MVNgr,6368,96368MVNgr-generic)
@@ -335,6 +334,8 @@ $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-8M-fla
 $(eval $(call CfeImageDTB,96328avng,bcm96328avng,96328avng,6328,96328avng-16M-flash-generic,,--pad 8))
 # Generic 96338GW
 $(eval $(call CfeImageDTB,96338GW,bcm96338GW,6338GW,6338,96338GW-generic))
+# Generic 96338W
+$(eval $(call CfeImageDTB,96338W,bcm96338W,6338W,6338,96338W-generic))
 # Generic 96345GW2
 $(eval $(call CfeImageDTB,96345GW2,bcm96345GW2,96345GW2,6345,96345GW2-generic))
 $(eval $(call CfeImageDTB,96345GW2,bcm96345GW2,96345GW2,6345,96345GW2-bc221,,--layoutver 5))
index 004f526..a997212 100644 (file)
@@ -37,7 +37,7 @@ Subject: [PATCH 48/48] MIPS: BCM63XX: add of_board_ids for all supported boards
  
  static struct board_info __initdata board_96338w = {
        .name                           = "96338W",
-+      .of_board_id                    = "brcm,96338w",
++      .of_board_id                    = "brcm,bcm96338w",
        .expected_cpu_id                = 0x6338,
  
        .has_uart0                      = 1,
index 30a17ab..eb17f95 100644 (file)
@@ -32,6 +32,15 @@ define Profile/96338GW/Description
 endef
 $(eval $(call Profile,96338GW))
 
+define Profile/96338W
+  NAME:=Generic 96338W
+  PACKAGES:=
+endef
+define Profile/96338W/Description
+  Package set optimized for 96338W.
+endef
+$(eval $(call Profile,96338W))
+
 define Profile/96345GW2
   NAME:=Generic 96345GW2
   PACKAGES:=