generic/4.0: upgrade to 4.0-rc5
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Mar 2015 14:06:42 +0000 (14:06 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 26 Mar 2015 14:06:42 +0000 (14:06 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@45025 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-version.mk
target/linux/generic/patches-4.0/070-bgmac-register-fixed-PHY-for-ARM-BCM470X-BCM5301X-ch.patch
target/linux/generic/patches-4.0/071-bgmac-allow-enabling-on-ARCH_BCM_5301X.patch
target/linux/generic/patches-4.0/655-increase_skb_pad.patch
target/linux/generic/patches-4.0/656-skb_reduce_truesize-helper.patch
target/linux/generic/patches-4.0/666-Add-support-for-MAP-E-FMRs-mesh-mode.patch
target/linux/generic/patches-4.0/668-fix-ipv6-throw-routes.patch
target/linux/generic/patches-4.0/680-NET-skip-GRO-for-foreign-MAC-addresses.patch
target/linux/generic/patches-4.0/721-phy_packets.patch
target/linux/generic/patches-4.0/902-debloat_proc.patch

index 29333aa..16f76e7 100644 (file)
@@ -7,14 +7,14 @@ LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
 LINUX_VERSION-3.14 = .35
 LINUX_VERSION-3.18 = .9
-LINUX_VERSION-4.0 = -rc4
+LINUX_VERSION-4.0 = -rc5
 
 LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
 LINUX_KERNEL_MD5SUM-3.14.35 = e5e92c40d14bc8ae9a8701db4e1cbb27
 LINUX_KERNEL_MD5SUM-3.18.9  = 44cd16ada5eb03589f696f083cd2323b
-LINUX_KERNEL_MD5SUM-4.0-rc4 = 0e37c076159538ff882f190d87fe9798
+LINUX_KERNEL_MD5SUM-4.0-rc5 = b26150c980099ef554b26d07f470e647
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 472b22b..9f0baff 100644 (file)
@@ -17,8 +17,6 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  drivers/net/ethernet/broadcom/bgmac.c | 34 ++++++++++++++++++++++++++++++++++
  1 file changed, 34 insertions(+)
 
-diff --git a/drivers/net/ethernet/broadcom/bgmac.c b/drivers/net/ethernet/broadcom/bgmac.c
-index 0469f72..efda7cf 100644
 --- a/drivers/net/ethernet/broadcom/bgmac.c
 +++ b/drivers/net/ethernet/broadcom/bgmac.c
 @@ -14,6 +14,7 @@
@@ -29,7 +27,7 @@ index 0469f72..efda7cf 100644
  #include <linux/interrupt.h>
  #include <linux/dma-mapping.h>
  #include <bcm47xx_nvram.h>
-@@ -1330,13 +1331,46 @@ static void bgmac_adjust_link(struct net_device *net_dev)
+@@ -1330,13 +1331,46 @@ static void bgmac_adjust_link(struct net
        }
  }
  
@@ -76,6 +74,3 @@ index 0469f72..efda7cf 100644
        mii_bus = mdiobus_alloc();
        if (!mii_bus)
                return -ENOMEM;
--- 
-1.8.4.5
-
index 674d561..3c5b79d 100644 (file)
@@ -15,8 +15,6 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  drivers/net/ethernet/broadcom/Kconfig | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/drivers/net/ethernet/broadcom/Kconfig b/drivers/net/ethernet/broadcom/Kconfig
-index ee4fdfe..a6f9142 100644
 --- a/drivers/net/ethernet/broadcom/Kconfig
 +++ b/drivers/net/ethernet/broadcom/Kconfig
 @@ -142,7 +142,7 @@ config BNX2X_SRIOV
@@ -28,6 +26,3 @@ index ee4fdfe..a6f9142 100644
        select PHYLIB
        ---help---
          This driver supports GBit MAC and BCM4706 GBit MAC cores on BCMA bus.
--- 
-1.8.4.5
-
index 5a56fbb..e531716 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2019,7 +2019,7 @@ static inline int pskb_network_may_pull(
+@@ -2026,7 +2026,7 @@ static inline int pskb_network_may_pull(
   * NET_IP_ALIGN(2) + ethernet_header(14) + IP_header(20/40) + ports(8)
   */
  #ifndef NET_SKB_PAD
index 7bb856a..6a2fb89 100644 (file)
@@ -14,7 +14,7 @@ when needed.
 
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2064,6 +2064,24 @@ static inline void pskb_trim_unique(stru
+@@ -2071,6 +2071,24 @@ static inline void pskb_trim_unique(stru
        BUG_ON(err);
  }
  
index cf5737d..92f7e62 100644 (file)
@@ -332,7 +332,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        memcpy(p->name, u->name, sizeof(u->name));
  }
  
-@@ -1633,6 +1791,15 @@ static int ip6_tnl_validate(struct nlatt
+@@ -1634,6 +1792,15 @@ static int ip6_tnl_validate(struct nlatt
        return 0;
  }
  
@@ -348,7 +348,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  static void ip6_tnl_netlink_parms(struct nlattr *data[],
                                  struct __ip6_tnl_parm *parms)
  {
-@@ -1666,6 +1833,46 @@ static void ip6_tnl_netlink_parms(struct
+@@ -1667,6 +1834,46 @@ static void ip6_tnl_netlink_parms(struct
  
        if (data[IFLA_IPTUN_PROTO])
                parms->proto = nla_get_u8(data[IFLA_IPTUN_PROTO]);
@@ -395,7 +395,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  }
  
  static int ip6_tnl_newlink(struct net *src_net, struct net_device *dev,
-@@ -1718,6 +1925,12 @@ static void ip6_tnl_dellink(struct net_d
+@@ -1719,6 +1926,12 @@ static void ip6_tnl_dellink(struct net_d
  
  static size_t ip6_tnl_get_size(const struct net_device *dev)
  {
@@ -408,7 +408,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return
                /* IFLA_IPTUN_LINK */
                nla_total_size(4) +
-@@ -1735,6 +1948,24 @@ static size_t ip6_tnl_get_size(const str
+@@ -1736,6 +1949,24 @@ static size_t ip6_tnl_get_size(const str
                nla_total_size(4) +
                /* IFLA_IPTUN_PROTO */
                nla_total_size(1) +
@@ -433,7 +433,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
                0;
  }
  
-@@ -1742,6 +1973,9 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -1743,6 +1974,9 @@ static int ip6_tnl_fill_info(struct sk_b
  {
        struct ip6_tnl *tunnel = netdev_priv(dev);
        struct __ip6_tnl_parm *parm = &tunnel->parms;
@@ -443,7 +443,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  
        if (nla_put_u32(skb, IFLA_IPTUN_LINK, parm->link) ||
            nla_put(skb, IFLA_IPTUN_LOCAL, sizeof(struct in6_addr),
-@@ -1752,8 +1986,27 @@ static int ip6_tnl_fill_info(struct sk_b
+@@ -1753,8 +1987,27 @@ static int ip6_tnl_fill_info(struct sk_b
            nla_put_u8(skb, IFLA_IPTUN_ENCAP_LIMIT, parm->encap_limit) ||
            nla_put_be32(skb, IFLA_IPTUN_FLOWINFO, parm->flowinfo) ||
            nla_put_u32(skb, IFLA_IPTUN_FLAGS, parm->flags) ||
@@ -472,7 +472,7 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
        return 0;
  
  nla_put_failure:
-@@ -1777,6 +2030,7 @@ static const struct nla_policy ip6_tnl_p
+@@ -1778,6 +2031,7 @@ static const struct nla_policy ip6_tnl_p
        [IFLA_IPTUN_FLOWINFO]           = { .type = NLA_U32 },
        [IFLA_IPTUN_FLAGS]              = { .type = NLA_U32 },
        [IFLA_IPTUN_PROTO]              = { .type = NLA_U8 },
index f21e6f4..283ffce 100644 (file)
@@ -19,11 +19,9 @@ Signed-off-by: Steven Barth <cyrus@openwrt.org>
  net/ipv6/fib6_rules.c | 1 +
  1 file changed, 1 insertion(+)
 
-diff --git a/net/ipv6/fib6_rules.c b/net/ipv6/fib6_rules.c
-index b4d5e1d..27ca796 100644
 --- a/net/ipv6/fib6_rules.c
 +++ b/net/ipv6/fib6_rules.c
-@@ -104,6 +104,7 @@ static int fib6_rule_action(struct fib_rule *rule, struct flowi *flp,
+@@ -104,6 +104,7 @@ static int fib6_rule_action(struct fib_r
                                goto again;
                        flp6->saddr = saddr;
                }
@@ -31,6 +29,3 @@ index b4d5e1d..27ca796 100644
                goto out;
        }
  again:
--- 
-2.1.4
-
index a192960..48d73d1 100644 (file)
@@ -102,7 +102,7 @@ Signed-off-by: Felix Fietkau <nbd@openwrt.org>
        return 0;
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1589,6 +1589,8 @@ struct net_device {
+@@ -1592,6 +1592,8 @@ struct net_device {
        struct netdev_hw_addr_list      mc;
        struct netdev_hw_addr_list      dev_addrs;
  
index 1ace035..0f9e2f1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/netdevice.h
 +++ b/include/linux/netdevice.h
-@@ -1257,6 +1257,7 @@ enum netdev_priv_flags {
+@@ -1260,6 +1260,7 @@ enum netdev_priv_flags {
        IFF_XMIT_DST_RELEASE_PERM       = 1<<22,
        IFF_IPVLAN_MASTER               = 1<<23,
        IFF_IPVLAN_SLAVE                = 1<<24,
@@ -8,7 +8,7 @@
  };
  
  #define IFF_802_1Q_VLAN                       IFF_802_1Q_VLAN
-@@ -1284,6 +1285,7 @@ enum netdev_priv_flags {
+@@ -1287,6 +1288,7 @@ enum netdev_priv_flags {
  #define IFF_XMIT_DST_RELEASE_PERM     IFF_XMIT_DST_RELEASE_PERM
  #define IFF_IPVLAN_MASTER             IFF_IPVLAN_MASTER
  #define IFF_IPVLAN_SLAVE              IFF_IPVLAN_SLAVE
@@ -16,7 +16,7 @@
  
  /**
   *    struct net_device - The DEVICE structure.
-@@ -1556,6 +1558,11 @@ struct net_device {
+@@ -1559,6 +1561,11 @@ struct net_device {
        const struct ethtool_ops *ethtool_ops;
        const struct forwarding_accel_ops *fwd_ops;
  
@@ -28,7 +28,7 @@
        const struct header_ops *header_ops;
  
        unsigned int            flags;
-@@ -1621,6 +1628,10 @@ struct net_device {
+@@ -1624,6 +1631,10 @@ struct net_device {
        struct wireless_dev     *ieee80211_ptr;
        struct wpan_dev         *ieee802154_ptr;
  
@@ -41,7 +41,7 @@
   */
 --- a/include/linux/skbuff.h
 +++ b/include/linux/skbuff.h
-@@ -2050,6 +2050,10 @@ static inline int pskb_trim(struct sk_bu
+@@ -2057,6 +2057,10 @@ static inline int pskb_trim(struct sk_bu
        return (len < skb->len) ? __pskb_trim(skb, len) : 0;
  }
  
@@ -52,7 +52,7 @@
  /**
   *    pskb_trim_unique - remove end from a paged unique (not cloned) buffer
   *    @skb: buffer to alter
-@@ -2176,16 +2180,6 @@ static inline struct sk_buff *dev_alloc_
+@@ -2183,16 +2187,6 @@ static inline struct sk_buff *dev_alloc_
  }
  
  
  
  #include <net/protocol.h>
  #include <net/dst.h>
-@@ -550,6 +551,22 @@ struct sk_buff *__napi_alloc_skb(struct 
+@@ -550,6 +551,22 @@ struct sk_buff *__napi_alloc_skb(struct
  }
  EXPORT_SYMBOL(__napi_alloc_skb);
  
index b30bd7d..26a2175 100644 (file)
                goto err;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2952,6 +2952,8 @@ static __net_initdata struct pernet_oper
+@@ -2956,6 +2956,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {