6rd: make host dependency more specific
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Mar 2015 08:43:54 +0000 (08:43 +0000)
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Mar 2015 08:43:54 +0000 (08:43 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44636 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/ipv6/6rd/Makefile
package/network/ipv6/6rd/files/6rd.sh

index d3e4bf6..f9b7eae 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6rd
-PKG_VERSION:=8
+PKG_VERSION:=9
 PKG_RELEASE:=1
 PKG_LICENSE:=GPL-2.0
 
index 287f569..b485136 100644 (file)
@@ -23,7 +23,7 @@ proto_6rd_setup() {
                return
        }
 
-       ( proto_add_host_dependency "$cfg" 0.0.0.0 "$tunlink" )
+       ( proto_add_host_dependency "$cfg" "$peeraddr" "$tunlink" )
 
        [ -z "$ipaddr" ] && {
                local wanif="$tunlink"